PDA

View Full Version : Huge Fps drops occuring.



LoveSwagu
03-07-2017, 08:12 PM
Okay so i dont understand this at all. When i played open beta i had like absolute 0 problems with my fps it was solid 40-60 all the times. But now geesh, havent been able to play more than the first mission because it jumps from 20-50 all freakin time. And if i try to drive a vehicle or fly heli jesus it just gets worse than that. I deleted like 100gb worth of files from my pc (i was low on space) didn't help, i tried to play it on low settings and that didn't work too. I also updated my gpu drivers and also shut down every other process i could but still nothing works. Im starting to get desperate because after all it worked just fine in open beta few weeks ago.

TheDevilman65
03-08-2017, 03:25 PM
I was having the same experience. Game played just fine during the open beta, but on release I am getting 20-30 FPS and very choppy play. So bad you just cannot play the game. I was also getting nonstop notifications in the game of "Input device detected or connected". I had my Logitech extreme 3d pro joystick plugged in to a usb port. So on chance I unplugged the joystick and the game instantly jump back up to 60 fps and the choppiness went away. Plugged the joystick back in and fps dropped and game went choppy again. If you have a joystick or something else plugged in try removing it and see it that helps any.

LoveSwagu
03-12-2017, 07:44 PM
Okay so i dont have any glue what i did but the game runs now fine. The only problem still is that my Ram usage jumps from 40% to 99% and it just ****s up everything up. And after installing this game non of my other games have worked because "too high ram usage" even tho i would been using only 70%

DontTouchMyHoHo
03-12-2017, 09:14 PM
Having massive fps drops of 30 frames. Running 780ti 3gig vram weith 8 gig ram i7 6700k and at times i can play very high/ultra settings with 60+fps no problem and sometimes when I load the game I get 30 fps on low settings.