View Full Version : Warden not Working

03-02-2017, 02:14 PM
Hey there.

Playing on PC

I played my Warden to almost Veteran 2 but there are alot of things bothering me:

Combos don't work. I know this might sound stupid but when I test a combination of keys on thin air all works just fine. For examble the shoulder-bash-charge. If there is one opponent it doesn't go off 6 times before it goes off once.

Double-Slash doesn't work as well, same for the supposed to be quick Overhead slash (which also never triggers double). Before my Warden even starts an light attack he weirdly gets stuck in changing his stance or something which is a brutal delay of up to 400ms and then he starts the animation for a hit. Needless to say that you will just get slaughtered if everything is even slower than it is supposed to be...

Another thing, that might have the same issue as the issues stated above:
Blocking: Especially against fast attacks: It's just impossible even if I moe my mouse slightly before the attack comes in it will definitely hit me.

Whenever I counter-parry an enemy they stagger out of range, so I am punished for taking the risk of counter-parrying? (As mentioned the shoulder charge thing practically never goes off. It goes off however whenever I throw someone off a cliff, then he tries to charge into the same hole....)
When I parry an enemy my next quick attack will be slower than his fast and heavy attack. (sometimes one overhead slash finds its mark, the second which is supposed to be unblockable is parried, so I don't think the double strike triggered)
Whenever I dodge my following fast attack will also be slower than any attack performed by my opponent.
Starting my blockbreak early, the enemy starts his way later: Mine is ignored entriley but his blockbreak hits me and is additionally un-counterable.
Usually the Warden should be making a big step to hit an enemy that's a little farther away, mine doesn't he grabs and hits thin air, is instantly out of stamina and gets wrecked.

Currently I am just at the point of bitter loughing since nothing works and everyone is simply faster than me and can spam light attacks the moment I start to swing my sword or they'll just blockbreak me right after I started a attack (isn't that supposed to be impossible?).

And then there are times when the game runs incredibly smooth and everything works, but those times are about a week past.
I tried to update my drivers, lower the graphics (frame rate caps at 30 fps but has 79 fps in the benchmark) but nothing helps.

I don't know if all this is intentional or just a bug, it's been driving me to complete rage since nothing I do seems to go off fast enough to even touch anyone. I also haven'T found any similar threads anywhere.

I figured it might be my controls but when I play the Warlord everything works perfectly so what the hell is the matter with my warden?

Best regards

Edit: Just tried against Bots:
- Double strike is totally random but didn't go off 8/10 times.
- Bots are also quicker with their attacks after I just counter-parried them
- Flaming shoulder charge doesn't work at all
- Strong counter from top never works especially against fast enemies... which brings me to: why the **** is a kensei, with the biggest sword that ****ign fast? Did they ever hold a sword in their own hands before making this game o.O?