View Full Version : Why can no one join my party???

02-24-2017, 08:40 PM
I run consistently at 100mbps, usually always have a green connection while in game. I play other games with ZERO latency issues.

Why can none of my friends join my parties in For Honor? The first week the game came out they could, now... no one can join. This is after like 10 attempts over a couple of days.

02-24-2017, 08:51 PM
One thing I noticed is that when you invite friends their attempt to join you sometimes refuses to work if you're already in a game lobby getting ready to go into a match. Try sending your invites all the way back from the main menu instead.

02-24-2017, 09:02 PM
Yes, it happens all the time. Usually it fails after my party member "failed to join session" when we try to join a match. Earlier, it failed just sitting on the main menu, just starting up the game. This game is broke on almost every level.

02-24-2017, 09:11 PM
wish i could say that fixed it, but it didnt

02-24-2017, 11:21 PM
wish i could say that fixed it, but it didnt

After about 20 minutes, my three friends and I made a group of four. Friend A couldn't invite Friend B, but Friend B could invite Friend A with no problem. After trying many combinations of invitations between Friends A, B, C, and D, we finally made a group. Of course, two-thirds of the matches DC'd mid match naturally.

If you don't understand how it could be this bad, you don't understand Ubisoft. They make some good games, but they have absolutely zero idea what the "internet" is and that it is important to their games. Heroes of Might and Magic 6 required an online connection to Ubi, and when it was lost, your entire coop game not only disconnected, but you couldn't recover it. Had to restart, only to be DC'd again, and lose your campaign again.

They have the absolute worst technical execution of any gaming company.