View Full Version : Assassin's Creed IV: Black Flag won't connect to Ubisoft servers

02-15-2017, 09:28 PM
As the title says, i'm stuck on connecting to ubisoft servers! Multiplayer does not work either. I've tried setting up my firewall, turning on game mode in it, restarting etc. with no luck. Any other Uplay games I have works problem free, they connect to servers as well. Any advice?
Thx in advance!

02-15-2017, 11:42 PM
ACIV BF doesn't save to cloud so I do not know if turning that off might help... I'm not aware of any other server issues or whether any specific ports need forwarding to play but I'll look around and edit this post later

I've seen some players with limited connection which I believe is fixed with the Ubisoft passport but apart from that I found this

02-16-2017, 09:49 AM
I tried everything you suggested, but unfortunately nothing helped. The game still can not connect to ubisoft servers. Because of this, the game does not unlock club actions and game progression witch is very annoying!

03-12-2017, 10:33 AM
I have same issue. I can't connect to ubisoft servers and I tested everything about port / fw etc... I have public IP address without NAT and I'm still offline.

02-18-2018, 02:27 PM
I cant connect either. It just says "connecting to Ubisoft...." but it never does. I can, however play multiplayer but not get online when playing the main game, also I can't play Kenway's fleet. When I try it doesnt even say I'm offline or online. Just the cursor and that blueish, glittery background. What gives?

02-18-2018, 02:49 PM
I don't have over 99 friends on my friendslist, still it just wont connect to the server.

And when I try to play Kenway's Fleet I only get:

NOTHING HAPPENS!! And last week it was just fine and I can still play MULTIPLAYER but NOT the campaign!?