View Full Version : White screen

01-28-2017, 08:28 AM
Assassins Creed tries play in Windows 10 operating system, I get a white screen with sound

01-28-2017, 12:33 PM
do you mean the original, first assassin's creed game?

Also it will help to see your pc specs. Are you playing on a laptop? if you are, are you using the dedicated card or the integrated graphics?

verify your game files and run the game and uplay as administrator

try the game in compatibility mode

01-28-2017, 06:44 PM
I have played all Assassin's Creed games on Windows 10 without any problems.
Please post your specs as strigoi suggests and please also let us know which game it is you're having problems with.

02-13-2017, 03:33 AM
Hello all,

I am having this same issue.
Running the original Assassins Creed.

I'm using the latest 2016 Macbook Pro dual boot into Windows 10. I've played many other games this way without issue.
The game seems to install just fine, I get to the save game menu, try to start a new game and it just stays at an animated loading screen.

I have tried uninstalling/reinstalling the game, running as administrator, and verifying the game files.

I have my specs and a vid of the issue attached. Any help would be greatly appreciated!!

Just noticing the specs say I am running Vista... definitely not. I'm running Windows 10 Pro. Not sure what to do about that.


https://www.dropbox.com/s/oiliz5nqnjpbpft/Assassin%27s%20Creed%202_12_2017%209_21_12%20PM.mp 4?dl=0

02-13-2017, 07:00 AM
Which version are you running? Dx9 or Dx10?
Have you tried setting Vsync to On?

02-15-2017, 09:51 PM
Currently running DX 12 as shown in the screen shot. Where would I set vsync? Inside As Creed app?

Ok, So I have tried both the Dx9 and Dx10 versions with vsync On. Vsync on seems to help... a bit. Still gets stuck on the loading screen after clicking new game, but now there is actual text that says loading and some extra imagery that comes up. Any other thoughts?

02-15-2017, 10:18 PM
I've never tried running Windows on a Macbook, so I don't know if that is the problem. I do however know that laptops are officially not supported by any of the AC games, so perhaps it's a combination of running windows on a Macbook and the fact that you're trying to play the game on a laptop.