View Full Version : AC Brotherhood - Bug (?) Can't start sequence 9

01-16-2017, 09:15 PM
Saving immediately after sequence 8, I tried to play the game the day after, but could not start sequence 9. I was back in Rome and stuck there. I can't go to Monterioggioni. There seems to be no way for me to start sequence 9 (no exclamation mark on the map in Rome). Have tried replaying the memory 8, but that just brings me back to the main menu after completion.

I play on PS4. Is this a known bug? Or does anyone know of a solution?

02-19-2017, 08:01 PM

I've had the same issue. I quit straight after starting Sequence 9, and when I came back on a few days later I was stuck in Rome with seemingly no way of starting the sequence. I have tried leaving the animus and going back in, replaying the last memory of Sequence 8, going to the part of the map where you find the Apple, playing another mission to see if it would add the story mission to the map upon completion. Nothing seems to work...

I emailed Ubisoft support on the 4th of this month. I dont know how efficient they are, but I believe I read that I should expect an answer within 5 working days (slightly longer if they are busy). 2 weeks later and Ive heard nothing.

Can anyone please help? Or are we just screwed and will have to replay the whole game to get to Sequence 9 again?

I also own the PS4 version.

Any help would be greatly appreciated!

Thank you.