View Full Version : Assassins Creed 1 - Downloaded / Crashed / Failed to verify files (2X)

01-10-2017, 09:03 PM
I downloaded a new copy of Assassins Creed 1, then it crashed when creating a new game, and then I verified with Uplay and it detected corrupted files that could not be repaired, telling me to unistall and download again. Then I do it again and it happens again.
Is it happening to anyone besides me?

01-11-2017, 07:42 AM
I finished Assassin's Creed (dX 10 version) on Windows 10 a couple of weeks ago, the only issue I'm aware of is the need to enable V-Sync on newer computers. This applies to AC II and Brotherhood as well.

01-11-2017, 11:42 AM
I know that we can install games on a secondary drive and play them but I saw a post that said the person had to install ac1 on the primary drive (the boot drive where windows is installed) so if you have it installed on a secondary drive you might try installing it on the primary. Also I remember on 1 rare occassion someone downloading a game from one server and the file was corrupt at the server. I'd be surprised if that happened again. If you cannot get it working by running it in compatability mode on the primary drive and running it as administrator then you need to contact Ubisoft support

01-12-2017, 06:56 PM
Just thought i would share my experience for others. The Ubisoft logo was fine, then the screen went black where it says " Ubisoft presents a Ubisoft Montreal production....." then it came good again on next screen. But when the intro started, i had audio but, screen was black. I tried moving all files to primary hard drive. dDdnt work. I tried the V-sync when i could get to options, but again, didnt work.
I tried the " Disable display scaling on high DPi settings", but didnt work.
I tried the DX9 version, that ran fine, which told me it was something to do with DX 10. I cam across this link : http://forums.ubi.com/showthread.php/727336-Finally-discovered-the-DX10-problem-with-the-first-Assassin-s-Creed-Forums
Which gave me the idea to try other settings in the properties tab. I tried running as admin, again the disable display scaling, then both the disable scaling and running as admin, none of those worked. Only thing that did work, was either running DX 9 version, or checking the box for " Run this program in compatibility mode for : ", Then i just tried the first option being, Window XP (Service Pack 3). SO FAR , touch wood, it is working fine. The only thing is, UPlay will no longer start the game, AND i sent a shortcut to the desktop for the DX 10 version because UPlay wont open it anymore. Hopefully Ubisoft might do something about this in the near future. BUT, at least there are alternatives to get it working and i hope this helps others :)

01-12-2017, 08:59 PM
I just had a look at the compatibility settings for my AC game and I don't have anything checked on the compatibility tab. I don't even run the game as an administrator and it runs just fine, go figure...
Also I don't have the first AC game in Uplay, because it was released before UBI even created Uplay and jemce it has no connection to Uplay.