View Full Version : Kind of angering...

01-10-2017, 06:16 AM
Okay, I've been having this issue for quite a while now and have been trying to fix it for the last few days with no success.

It took me quite a while to finally buy my copy of Primal which I was waiting for a loooong time until I finally could, and together with it, I bought Far Cry 3.

On both games I'm having the same issue, it seems, and even though I've read hundreds of fixes online and tried just about everything, NOTHING seems to fix it.

Situation seems to be a random crash on both games that are happen exactly the same way. The game suddenly freezes, than the desktop shows for a second. background/ambient sound continues while all game sounds of battle and anything else disappear.
At this moment, on Far Cry 3 I'm looking at a black screen while on Primal I seem my desktop or whichever window is opened with no mouse, but the issue is the same.

This first started on 3 and I've tried for a long time to fix it, but nothing seems to even change the time it takes to crash. This crash doesn't seem to have any reason, it just happens after a few minutes of playing, sometimes for a long time, sometimes almost instantly, and I can't find a single crashlog that might provide me with at least an idea of what is causing it so I can at least think of a way to solve it for good.

On both games, I tried setting the binaries for administrator, remove theme, everything, if you can type the issue on google and find a solution, I've already tried that and it did not happen, please, DO NOT suggest solutions that you can already find around, none of that worked and I did try.

Changed SSAO to HBAO or HDAO, changed video quality, borderless, reinstalled every single Redistributable, every single .Net Framework, checked integrity of game cache, compatibility modes, EVERYTHING, even uninstalling the DLC's to see if they are causing it somehow.

My computer is not the best, but it serves me pretty well and it does run the game quite well with a moderate setting.
4GB Ram
Radeon HD 6670 2GB VRAM
2.80 GHz Processor AMD Phenom II x4
System Rating 6,7 on Windows Index.

If someone has an idea on what might actually be causing this, please, do help. I really like both games, a LOT, but if I do not find a solution, I will have to ask for a refund, as no matter how much I loved it, a game that does not work will not serve me and I bought them really recently, so I still can ask for this refund, even though I don't really want to.

A LOT of people are having this issue but I have not found a single person who actually knows what is causing it and a lot of guesses on what MIGHT be the problem and what MIGHT solve it, though I need something more concrete, an actual fix or someone from Ubisoft who could actually provide a few words on what, why and how long until it does not happen anymore.


01-16-2017, 02:56 AM
I had stability problems with FC3 a long time ago - the problem for me was the Phenom CPU - I switched to a newer FX (same mobo) and this problem vanished. Never seen this problem again.

01-16-2017, 03:35 AM

01-16-2017, 04:21 AM
(Unfortunately, this does not seem to have fully fixed the same problem in Farcry Primal as it still stops working)[/QUOTE]

Well if that is good enuf for ya - fine with me otherwise dump the old CPU!