View Full Version : Can't play AC3 singleplayer it stops working

12-11-2016, 05:53 PM

I just got this game for free and wanted to play the singleplayer but i can't because it keeps crashing.
I use ac3 as admin, launching in a different compatiblity, updating my driver and verifying my files but noting works. How can i fix this?

THe multiplayer howerver does launch but without sound and i know which sounds i am supposed to hear because i bought this game on ps3 at release and that version works fine.
So anyone have a fix?

12-11-2016, 06:04 PM
you could try these solutions

12-11-2016, 06:18 PM
Tried it but it didn't work

12-12-2016, 02:10 AM
can you list your pc specs please

12-15-2016, 01:34 PM
Only the singleplayer fails for me (the MP starts OK).
The SP shows the usual white text on black background about various cultures etc on start then stops working.

My specs are:
Intel i7-3770K (4 cores / 8 threads / 3.6 Ghz)
16 GB RAM @ 1600Mhz
Geforce GTX TITAN (6GB VRAM) @ 2560x1440 60Hz
Windows 10 Pro with latest updates installed and with latest Geforce drivers

12-15-2016, 03:17 PM
Hmm your system is similar to mine except you are running on win 10 pro while I have the basic win 10. I did notice someone else with pro with problems, have you tried running AC3SP.Exe in compatibility mode?

I'm assuming you have Uplay and ACúSP.Exe running as administrator and you have uplay overlay turned off. (Also steam overlay if steam is running)
I'm also assuming you have verified the game files (I usually do that twice just to be certain), and you did a (real) clean install of Nvidia drivers using wagnards DDU.exe. Plus tried playing with antivirus and firewall disabled.

Have you tried to rename your save folder? Sometimes when the game tries to save it causes the game to crash, My save folder is in
C:/Program files (x86)/Ubisoft/Ubisoft game launcher/ savegames/ (folder with lots of letters)/ 54

I usually rename it to 54a then run AC3 and if the game runs well, you can go back into 54a and copy the saved games into the new 54 folder... but only if you have got a long way into the game

12-15-2016, 05:01 PM
Hmm. Verifying the files actually found errors and fixed the problems.
I am interested how the files got corrupted in the first place. Never had an issue like that with any game before, and I have many games...

Anyways. Thanks for the help.

12-15-2016, 06:09 PM
Always happy to help a fellow Assassin :) There's always a slight possibility of a little data corruption when writing to disk, especially downloaded data. There's no point having a great gaming system like that if you cannot put it to good use.