View Full Version : Game crash on loading screen

12-04-2016, 09:51 PM
The game starts up and connects to steep servers then on "loading, please wait...(1/3) " screen the game crashes
tried already to reboot, reinstall Uplay and steep, delete savegame folder, delete documents/mygames/steep folder still the same game crashes
pls give me spome hint what i csan do else
no it is not possible to send a scrennshot

12-05-2016, 09:05 AM

12-05-2016, 12:27 PM
I have the same problem, here's my screenshot.


12-05-2016, 01:45 PM
first, sorry for my bad english.....

I got the same problem. but i canīt see the problem listet at the known issues..... i think thats not an accident.

the problem is knwon since the open beta but the most people can play so its probably not so important for ubisoft.
i played this wonderful game in the closed beta, everything was fine. then there was the open beta and all ****ed up. I thought ok until the release they'll get it already...... not

i try so often the FAQ help but, nothing helps, an since friday. from the customer support not one answer to my ticket, i told them i give a **** on a generated answer because i hoped i get usefull one from a employee
i am really frustrated, so i decided to wait till they fix it, i think in a half year its maybe playable. right to the summer time.

yesterday i gave back my game in steam, very friendly and quick customer support by the way.

Ubisoft we pay the money for games so get them running, do not fool us.

12-06-2016, 04:36 AM

12-06-2016, 10:48 PM

12-06-2016, 11:20 PM
Exact same problem, all open beta was fine and for the first couple of hours on launch day I was able to play but now this. Any fixes? Haven't been able to play since Steep launched and pretty pissed off, paid for gold edition...

12-06-2016, 11:34 PM
Same issue I can't go further then the 1/3 step. I've tried rebooting, re-downloading and none of this stuff works, it's getting annoying :(

12-06-2016, 11:46 PM
same here as well tried everything but nothing helped still waiting for ubi support to react.......

12-07-2016, 10:00 AM
I have already sent tickets to Ubisoft, i guess this problem may be related to the process of accessing account to server. Did anyone quit game without pressing exit button?
If you have same problem, please send ticket to Ubisoft support, hopefully can aware them this problem is already particularly acute.

sorry for my poor English:(

12-07-2016, 03:39 PM
Same problem.. Stuck on 3/3 loading
Support said my problem cause of Laptop. They not officially support laptop :( but why?!

12-09-2016, 01:55 PM

12-09-2016, 09:31 PM
Hi all,
someone told me to do this and it helped.
I got the same problem (and some more with an USB 3.0 HDD), and he told me to deinstall Uplay and install it again in Admin mode (right click start as admin).
I deinstalled it (and all my related steep data from beta or the tries before) and installed Uplay (with admin mode) new.
And guess what, it worked, game started and worked fine.
Maybe you try this, more than losing a few data from deinstallation does not happen.

12-10-2016, 07:03 PM
This is fourth day I have tried to play Steep but I got that same prbolem ;((