View Full Version : Jack the Ripper Fails - ACS.exe not working

10-23-2016, 01:46 AM
AC Syndicate works perfectly (93% complete). I purchased Jack the Ripper DLC which downloaded OK. At the in game menu I select 'Continue' and AC loads my current game and proceeds as normal.
However, when I select Jack the Ripper from the in game menu it momentarily starts and then fails with the message 'ACS.exe has stopped working'.
I have verified the files in the Uplay properties menus and it reports all files valid.
I changed the Nvidia GPU driver from 373.06 to 365.1 but there is no change to the fail scenario
Any help with this is appreciated


My system is:
MSI Z97 gaming 5
Core i7 4790K
16Gb ram
Windows 10 Pro fully updated

10-24-2016, 06:42 AM
having the same problem

10-24-2016, 07:37 AM
Since posting the thread I have uninstalled and reinstalled AC Syndicate, verified the files again, lowered my resolution, and lowered the graphics to low quality.
Still crashing on Jack the Ripper

10-24-2016, 12:03 PM
Yeah I have tried all of those as well apart from reinstalling which would take way to long with my slow internet but if it didn't work for you I doubt it would work for me anyway. I have tried a few solutions that other people have found with ACS crashing (non worked) but cant find anything on jack the ripper failing

10-24-2016, 09:57 PM
This is happening due to the new patch released recently. The main game works fine but the DLC Jack The Ripper crashes upon launch.

10-25-2016, 12:01 AM
Is there a fix coming?
Can the recent patch be removed?

10-30-2016, 10:59 PM
i have the game finished but jack the ripper don't work. I have windows 10 pro.
pls admin answer to us. or guys how can i speak with one admin???

11-01-2016, 01:37 AM
Is there a fix coming?
Can the recent patch be removed?

Yeahhhhh that's a big fat no on removing the patch. No matter how many people have reported this outrageous screwup, Ubisoft won't allow any kind of downgrading.