View Full Version : Ubisoft your Support is a Complete Utter Joke (AC3 Issue)

10-15-2016, 07:25 PM
After recently purchasing every AC game from AC1 to AC3 on my pc everything works fine in every game until I get to AC3. After activating all my keys in AC3 for the dlc I open the game to play the Tyranny of King Washington dlc, however when I try to play it says "the ubisoft servers are unavailable". it thought this may be a small fluke and they were having an issue that day, no big deal. So I go back and check the next day and same issue. I continue to check every day for about two weeks and nothing. This would not be a big deal if it was just the multiplayer, but I can't even play the single player dlc to connection issues. Now this is when I decided to contact support and all I can say is the live chat support is completely awful. All they do is say the same thing over and over again with no progress in solving an issue. They instantly blame it on my connection which I donít understand how after every other AC game other than AC3 on my computer connects perfectly fine but AC3 is the issue. So they tell me to open up the ports on my router I do this and as I assumed nothing. Show support that and they just continue to be unhelpful. So I try to solve the issue on my own, by looking around the internet> I attempter using my phone as a hotspot in case my router was the issue and nothing. I tried reinstalling the game, as well as uplay, and nothing. I even posted on the AC subreddit and a person there told me to just wait it out, and that it can take up to a month for the game to allow you to connect because it happened to him for Brotherhood. If that is the solution then that is a complete joke first of all, but I guess I will still have to wait and see. I finally did come across a solution that seems like a person was having the same issue as me. He purchased the keys through a third party like I did, but for some reason there is connection issues with third party keys. I contact support once again show them this link and you know what they tell me, "try forwarding your ports". Like does this support have any competence at all, did you even look at the link. The community manager was the person who responded in the post, and tried solving the issue. All I can say is ubisoft you either need to fix these issues in Uplay or get a much better support team because at the moment they are completely useless.

Here is the link to the forum post as well.

10-24-2016, 10:00 PM
I have had this problem before and believe it is a glitch. Try launching the game as in going directly into game play mode where you can run around and do stuff, then enter main menu while game is still running and try to access the servers ... you may find for some reason it now magically works.

10-25-2016, 08:57 AM
I have a similar issue. Recently purchased AC3 Season Pass and I'm unable to play The Tyranny or Single Player DLC due to server error. Actually I remember the game not being able to connect to server ever since I bought it over three years ago. I have an official physical copy not some third party key so that makes it even more weird cuz you would expect an official product to work properly. I bought Season Pass last week directly through Uplay. I contacted Support a few days ago but haven't received any reply yet.

10-25-2016, 10:12 AM
I'm affraid it's not only a server's issue : I also purchased the AC3 season on Uplay store few days ago, also had a "server error message", then a new surprise: the game ask me a valid key to play the washington DLC.... seems like DLC purchase links are a bit messy on uplay store.

10-26-2016, 07:42 PM
Like i said in this thread and another thread I had the same issue and I was finally able to get it fixed today. I was also getting the server error. Not sure if i can discuss the details here how it was fixed but I suggest you contact live chat like i did and got everything fixed pretty quickly.