View Full Version : Problem downloading AC Brotherhood

09-19-2016, 04:30 PM
I've bought AC: Brotherhood last week since it was the only AC game of the Ezio trilogy I havnt played yet. Everything went smooth, I got my key started my download... no problem whatsoever. But when the download reached ~50% of the download Uplay stopped the download and beneath the download bar it said: "UPlay is unable to start your download. Check that you have an active Internet connection and sufficient space on your hard drive then try again." After reading that I checked how much space was left (100GB) and if my Internet crashed, wich didnt happen since I was able to download completely fine via Steam. Then I started googling but it didnt seem like anyone else had the same problem as I did, only similiar ones on diffrent games like R6:Siege or AC4. After reading through those problems and trying out the diffirent ways of fixing it f.e. Reinstalling UPlay, moving installation folders, moving UPlay, running UPlay as Admin etc. and nothing worked I thought it might help to completely uninstall the half finished download of Brotherhood and redownload it. Everything went good until I reached 4,33 GB again (50%). After that UPlay told me again to check my Connection and disc space and since I've run out of ideas on how to fix it, I've hoped that someone in this forum would have an idea on how to fix it.

09-21-2016, 02:15 PM
I don't know this problem, but it sounds to me like you might have some stray half-built file that didn't get cleaned up. That could be hard to find, and I'm not sure where UPlay puts partial files.

Have you tried changing to a different folder location for the install? If it's an SSD then it probably won't make any difference at all, but it might with a HDD.