View Full Version : AC1 bug: Stopping in Mid Air

08-09-2016, 11:38 AM
I'm replaying AC1 for PC as part of my efforts to get 100% saves on the whole series, but it looks like I've already been stymied by a bug.

Throughout the game, whenever Altair makes a big jump from a high place, after falling a few seconds his momentum will stop, he'll hang for a moment in mid-air, then fall straight down. This didn't seem right to me, but hey, it's been several years. Maybe I just didn't remember it right.

At least that's what I thought until I started hunting flags. There's one flag in particular in The Kingdom, in the ruins on top of a pillar. The way to get this flag is to jump from a higher pillar which normally can just be grabbed as you fall. However, on my copy my momentum is stopped several feet short of the pillar, meaning there's no way for me to get this flag.

I've only found one other mention of this problem on the Steam forums. This post said that the issue could be fixed by dropping out of full screen mode. This doesn't work for me. I also tried several different resolutions; still no change.

Has anyone else encountered this? Is there any workaround?

08-10-2016, 05:53 AM
I found the solution! I'll post it here in case someone else has this issue.

The problem seems to stem from a very high framerate. Modern systems can easily run a game this old at hundreds of FPS. If you enable vertical sync in the graphics options, you'll be capped at 60 (or whatever rate you choose in the options). Turning vsync on fixed the problem and I got that dumb flag. It also seems to have eliminated some of the other odd glitches with cloth that had been happening, like people's skirts flaring out.

There's no logical reason I can think of for these bugs to be caused by high FPS, but you can't argue with results. So turn on vsync.

08-10-2016, 06:04 AM
Thanks Seneth!

Enabling vsync fixed the wierd dx10 issue I had with Altair bouncing off of the haystacks dieing when doing a leap of faith.