View Full Version : Assassin's Creed 4: Black Flag

06-16-2016, 07:41 PM
when I enter the game loggin in to ubisoft server, please wait and never connect!!!!!!
what can I do to loggin in to ubisoft server to play online?????????

06-17-2016, 12:28 AM
Make sure the game has access to the internet inside windows.

06-18-2016, 07:50 AM
Got the game last week. Everything works except the bloody "logging into ubisoft server". Which never gets connected.

Can't play "Kenway's fleet" for the same bloody reason neither collect points

06-18-2016, 04:45 PM

if you are sure there is no issue with your internet connection (maybe try deactivate your firewall, it can block the access to Uplay servers), I would advice you to contact our support: https://support.ubi.com


06-20-2016, 01:13 PM
Done everything from port forwarding, host file chaning, DNSflushing, deactivating the firewal...............everyythingl.... Uplay is working fine... but ingame it just shows connecting.....

that's it nothing beyond that.. Even generated a ticket days back... no reply on that yet... WTH UBISOFT...... This is so demeaning.

06-20-2016, 06:56 PM
yeah im having the same problem yet for some reason i could get in to naval thing but here is the result :/

and now i cant even close te screen :/


06-24-2016, 02:41 PM
They don't want to admit it, but they disabled the servers for this feature. I can't go into the Kenway's fleet neither on PC or on my phone.

06-24-2016, 05:25 PM
Hello all,,

no server has been disabled for AC Black Flag.

If you bought the game from Uplay Shop, please contact the support choosing "Uplay Shop" for category.

If not, please try the troubleshooting (https://support.ubi.com/en-gb/faqs/000018031/Multiplayer-Connection-Issues-in-Assassin-s-Creed-IV-Black-Flag/)explained on Support website.

If it doesn't help, you wll have to contact the support and provide them with your system files and Uplay launcher logs.

You can find this here (https://support.ubi.com/en-gb/faqs/000021185/Sending-a-Dxdiag-to-Support/)and there (https://support.ubi.com/en-gb/faqs/000021216/Sending-a-msinfo-report-to-Support/).


06-25-2016, 03:36 PM
Same problem, tried all - firewalls, port forwarding, anything. Uplay connects, in-game connection with servers don't work. Created a ticket 5 days ago - 20th of June, - and still no reply.
But. I ordered this game 6/8/16, priced 2,50 EUR, and don't have a key - and when I'm open in-game Uplay, it says "activate a key".