PDA

View Full Version : Unable to complete Chapter 2 Mission 3



WinterSoldier20
06-08-2016, 12:55 AM
Hello, recently i bought the game on Steam, The Complete Edition. The game works fine, but here's the problem, in the Chapter 2 Mission 3, where you have to build a warehouse in the island called Bradford Mine, it ask to research an uranium drill and activate the item in that warehouse, but when i activate the item, nothing happens, and it's supposed to appear some mines when i click in the item and a conversation from Lester. I tried to restart the mission several times but won't fix my problem. Glitch, bug, problem with my computer?, i dont know what is happening. And the game is updated to the latest version.http://imgur.com/kvzzQwF

Ubi-Cerisino
06-08-2016, 11:42 AM
Hello WinterSoldier20,

so you researched the drill in the laboratory, build the warehouse and tried to socket and activate the drill in the warehouse?
I am not sure why it doesn't work then the way it should.

Here is a walkthrough (http://anno2070.wikia.com/wiki/Mission_Three:_Solidarity) of that mission.
Maybe that helps. :)

If it still doesn't work, please contact the support (https://support.ubi.com/en-GB).

Let me know how it goes.
Ubi-Cerisino

WinterSoldier20
06-08-2016, 02:49 PM
I've already contacted Ubisoft Support, they can't help me with my problem, they sent me this message: "We are only able to assist with technical issues such as errors, freezes and crashes. We are unable to help with gameplay related queries". I watched a walkthrough video on Youtube, when the youtuber activate the uranium drill, some uranium mines and a conversation fom Lester appears. In my gameplay that won't happen, i activate the uranium in the warehouse, no uranium mines and no conversation from Lester appears. I'm just there stuck. I'm fustrated, spent $29.99 just to be stuck in a mission?

Ubi-Cerisino
06-08-2016, 05:41 PM
Strange.
You do build the warehouse on Lester's island and activate the drill there? You are not accidentally on the wrong island?
Is that the video (https://www.youtube.com/watch?v=U-06BYO6w9I) you saw?

If it just doesn't want to work, try checking your game data, or reinstall the game.

I hope it will work for you now.

Ubi-Cerisino

WinterSoldier20
06-08-2016, 08:39 PM
Yes, that's the video and yes, i builded the warehouse on Lester's island and activated the drill there. And wait, i forgot something, in that video, at the minute 8:12 , that building, called Fuel Element Factory is missing in my gameplay, is not there, is missing. I think that's why i can't progress.

pretendor91
06-22-2016, 02:09 PM
i got the problem that in chapter 2 mission 3 the uranium mines are not there.
also the Fuel Element Factory is missing.
i have tried the following to solve it.
restart all the missions and just play the questions.
restart all the missions and search the whole map so everything was visable.

and still the mines are missing and the factory. problem is i cannot proceed my game now. and did bought it for 20.00

so please help me cuz i really want to proceed!

WinterSoldier20
07-05-2016, 04:04 PM
Well friend, we have the exact same issue, i can't progress either, the only thing we can hope for is an update or patch to fix the problem. Greetings.