PDA

View Full Version : Game lost some of my medals



martinlastbandi
05-15-2016, 10:16 PM
Hi,

something got messed up with my medals. I've played the first 80 solo campaign races and got at least a bronze (and invoked a few jokers). Now some of my earlier races on the Series overview screen show that I didn't earn a medal. But when going to the track selection, it still show the medal I originally earned. As a result, it won't unlock the Blue series, saying I only have 38/80 medals needed. However, my total medal count at the top right shows 117 medals (plus I wouldn't have advanced to Green International w/o getting the previous 70 medals, right?).
Also, I now can't just re-rearn a bronze on these tracks where I lost the medal, because it still thinks I did get it, hence I'd have to beat each one to re-register.
Has anyone experienced the same? What's happening here?

Thanks,
Martin

Ubi-Alinoa
05-17-2016, 10:50 AM
To unlock the Blue series, you must have 80 SILVER medals so you still must have 42 Silver medals to play Blue tracks.

martinlastbandi
05-18-2016, 04:17 AM
To unlock the Blue series, you must have 80 SILVER medals so you still must have 42 Silver medals to play Blue tracks.

Hmm, but this screen shot should still have everything from 1-80 "lit up"

https://plus.google.com/photos/118054872422616730374/albums/6285862225634985089/6285862223343771778

Ubi-Alinoa
05-19-2016, 08:56 AM
Challenges where you haven't yet the Silver medal switch out so that you know which challenge you must drive again to get the Silver medal.
So that's why you feel having lost medals ;)

martinlastbandi
05-19-2016, 04:24 PM
Challenges where you haven't yet the Silver medal switch out so that you know which challenge you must drive again to get the Silver medal.
So that's why you feel having lost medals ;)

Gotcha, that makes sense now. Thanks for the support!