View Full Version : Help!!!

05-09-2016, 08:29 PM
I just downloaded Dawn of Discovery - Venice from the Ubisoft website and I used the Brumbek-Steam manual update to update to 2.1.

I want to use the World Editor 2 tool but every time I start it I get this error message:

"Unhandled exception has occurred in a component in your application. If you click Continue, the Application will ignore this error and attempt to continue."

When I press "Continue" this message appears " WorldEditor2.exe has stopped working"

The problem event name is: CLR20r3

Interestingly Tool One works just fine including the Addon but World Editor2 only crashes.

Can anyone help me??!!
Thanks In advance


05-27-2016, 12:22 PM
What version do you have there were two of them Ver 1.0 & 1.1.

06-18-2016, 03:58 PM

06-19-2016, 01:45 AM
I did some checking and It will not work with DOD sorry it will only work with Anno 1404. I still play the game here and there and I forgot about that. I mostly play the the Mod. Here is a link to the Mod. http://iaam1404.projectanno.de/start_eng.htm

06-20-2016, 04:09 PM
I've never used this mod. Does it work with the Venice edition and will it allow me to use the World Editor tool?

06-20-2016, 05:37 PM
The Mod it is for both DOD & 1404. Yes they are the same game but the Map editor was written for 1404. The Map Editor was written by a German. DOD is for the USA and 1404 was for the rest of the world. The mod was written by a German too and he put in a lot different stuff for the other series of the game.

I myself can't use the Editor because I have my game installed on another drive. You have to have the game installed on "C" for it to work too. I do have some maps made but they are really made for the Mod. I want to change them too but I can't. If you are in the USA you can get the 1404 Gold Edition off of eBay really cheap. Plus if you do that get the update for it 3.1 and do that before you run the game no key needed.

06-21-2016, 06:51 PM
On a previous hard drive I had DOD and some version of the World Editor installed and it worked fine. The major difference is that I don't have the ability to run programs as administrator on this computer. I don't know if that's whats preventing the world editor from running.

Will the iaam_3.4 mod allow me to use the World editor?

06-21-2016, 07:41 PM
It might it might not I basically only use the Mod. The problem I have is all my games install on another drive. The only difference between the Mod and game is you just adding that to the game. Is this somebody else computer and you are setup with account on it. It you don't have administer rights on the computer. I don't think it is going to matter you will still have the same problem.

06-21-2016, 08:08 PM
Why does Tool One work fine and not World Editor?

06-21-2016, 09:03 PM
Ok I might know what the problem is but I have to install my DOD on another computer. I think it might be the Update that you use. I'll get back to you on this.

06-22-2016, 08:40 PM
Sorry I haven't got back to but I'm waiting on the game to come in the mail. I only have DOD with steams. It will not work with that version.

06-23-2016, 05:17 PM

06-23-2016, 08:59 PM
Ok I loaded DOD and everything works fine it works off of the version of the game. I think where you updated to "I used the Brumbek-Steam manual update to update to 2.1"

I would start all over again uninstall everything You can save you save games. But I would delete everything else. But this time just leave everything alone. Plus you are using Uplay too right.

DOD really didn't have a 2.1 update. My DOD Venice is at 2.0.5008 The maps I have made work fine with it too.

06-25-2016, 05:17 PM
Thanks for the help. Unfortunately It still doesn't work. The folks over at Project Anno said the problem might be with the font my computer is set at. World Editor only works with settings at 100% and 150% fonts. My computer is currently locked at 125%. Thanks again.

06-25-2016, 10:34 PM
Ok just tested it and that is true that you can use the Map editor only with fonts at 100%. What you could do is may another account with the fonts at 100% just to make maps.