View Full Version : Old infamous fc64.dll problem, inside please!

05-02-2016, 07:18 PM
First heres my system specs:

Videocard: GTX 970 SLI@1580+/7800+
Processor: Dual Xeon E5-2678 V3@2.9+
Mainboard: Asus d10pe-d8 ws
Memory: 64GB Samsung 2133mhz Ecc
PSU: Seasonic X 1200W Gold
2 Samsung 840 Evo's(Raid 0/Main OS)
2 Samsung 950 M.2's(Game Programs/Raid Stripe Mode in Dynamic mode)

This is my first post on this site, so Heres my error after launching the game through uplay:

Problem signature:
Problem Event Name: APPCRASH
Application Name: FarCry4.exe
Application Version:
Application Timestamp: 552190c2
Fault Module Name: FC64.dll
Fault Module Version:
Fault Module Timestamp: 5521908b
Exception Code: c0000005
Exception Offset: 00000000000016a1
OS Version: 6.3.9600.
Locale ID: 1033
Additional Information 1: 4cfc
Additional Information 2: 4cfca7fb71b616a38c88253f6b356a44
Additional Information 3: 98c3
Additional Information 4: 98c350d00578737521de4aadebc9403f

This is on win 8.1 x64 9600 rtm build(lol, I went back to win 8.1 as I havent been on it for a long time and wanted to see differences between this and win 10, believe it or not, I have better overall experience with 8.1, To much BS with win10, LOL, I'll go back to it later, probably when pascal comes out.)

Anyways, I also tried this on win 10 build 14316 and the most current one, all does NOT work.

Offline does not work as well.

I also tried the game on my main os raid ssd's, the 840's, just to see if anything would change, and NOPE.

I also learned that certain nvidia drivers are known to crash and advised to use a older nvidia drivers, mainly 359.06 or before for best results, it does NOT work(tried on win 10 x64 latest build revision).

I also deactivated msi afterburner program from the task menu, shut off anti-virus, it still does NOT work.

Now heres the funny part, the prior system I had before I build this one, I gave to my dad, tried that on that system with win 10 x64, build revision 14316, it worked instantly without no hiccups.

I did everything from removing the .dll and re-verify the game files, TWICE, still does not work.

Also tried to download the .dll, put it in my wowsys64 folder, tried to do the cmd, it failed to go through, tried putting that .dll within the bin folder of the game, it does NOT work.

The system I gave to my dad had the following specs:

16gb g.skill ddr4 ram
intel I7 5820k @ 4.5ghz+
2 samsung evo 840's(raid 0 configuration)
Gtx 690 @ 1185mhz(core)
Enermax Revolution 1020w
Asus x99-a motherboard.

Thanks for your help guys.

05-02-2016, 10:10 PM
I think I might found the answer I been looking for and possible MANY others:


Here, take a look at this site, and absolutely read very carefully on the bottom most post.

This explains why the game wont work.

05-02-2016, 11:24 PM
And I did just that.

Thank god this motherboard has the option to disable/enable certain amount of cores per socket, It only works in this in this cpu configuration:

The # indicate's # of cores per cpu:

7/7 = Works, 7/8 = works, 8/7 = works, And the one we all have been looking for:

8/8 = FAILS.

So apparently On dual socket configuration such as this, anything over 15 cores / 30 logical cores = it will "NOT", I repeat, will "!NOT!" work period.

Going to try this with assassin's creed unity as it does the same thing, game goes to ubisoft logo for not even a split second then shuts off, BRB on this as I am re-downloading the game on to the m.2 drives.

Originally I thought it could be due to my chipset itself, a server based chipset, C612 as opposed to the x99.

Good thing this mobo has the ability to shut off certain amount of cores per socket and shut off HT(Hyper threading), very good for testing purposes, and in this case, yes.

Whats freaking funny is this:

I can run FFXI(very old ps2 ported mmorpg game), MGSV: TPP, Lost planet 2(Capped @ 32 cores/has to do with wowsys64 as 32 bit games being installed on a 64bit environment as a direct result, cpu cores only can be used is 32, for more info on this, please go to: https://msdn.microsoft.com/en-us/library/windows/desktop/aa384228%28v=vs.85%29.aspx & for more reference: https://en.wikipedia.org/wiki/WoW64)

Battlefield 4 works perfectly, and my other steam games works, so I was like wtf is this, farcry4 wont work?? Damn, thats just plain sad, despite having to do with the amount of cpu cores, I mean look at ffxi, look how old that game is, and it works perfectly, :(.

05-02-2016, 11:57 PM

I now can confirm 100% that it works now, just very recently tried to boot the game, Works good, I haven't went into the actual game, I only got so far as the main title screen, Before I couldn't even see a split second of the ubisoft logo during the initial booting of the game.

So there you have it folks, If you have a single socket based cpu thats over 7/8 and it won't function. try going into your motherboard bios and hopefully you have the option to disable/enable certain cores, try bringing the cores 8 first, if that don't work, then try 7, this should 100% work without any doubts.

Thank you everyone.