View Full Version : Assassin's Creed: Syndicate stuck on starting logo and Uplay making my RAMs go crazy

04-22-2016, 05:03 AM

I recently purchased Assassin's Creed Syndicate with the season pass. I was so happy at the idea to play that game.

However my happiness went away pretty fast as i only managed to run the game one time by launching it via nvidia.

I uninstalled and redownload the game 5 times and everytimes near the end of the download my computer freeze and then is incredibly slow. I checked in the task manager and i can see in the memory tab numbers randomly changing and going crazy (especially for uplay). The only solution is to force close my laptop. When i restart it, the download always lost a lots of memory. For exemple if i was at 52Gb of download, when i restart the computer, it is at 41Gb.

I read many forums and searched google to fix the launching problem, here is what i tried:
- uplay on c: and syndicate on d:
- uplay on c: and syndicate on c:
- uplay on d: and syndicate on d:
- manually updating my graphic card.
- manually install c++ and directX from the game support file.
- launching it from uplay, desktop, file folder, nvidia (all as administrator, it only worked one time via nvidia).

It always launch and when the logo appears, i hear a windows sound and then nothing happens. If i close the game from the task bar, i can see in the task manager that it is still running in the background. But if i close it from the task manager, then it seems completely closed.

So here are my 2 questions:
- Is there a way to download games from uplay without my rams go crazy?
- Is there a way to pass the launching logo? Or is a patch fixing that coming up soon?


Msi G72 6QF 078TW
Gtx 970m
8+8GB DDR4
256GB ssd (C:) + 1TB (D:)
Windows 10 64bit

04-22-2016, 07:52 PM
I bought the game and for the longest time it refused to install both from the CD *** well as from Uplay. eventually i did manage to install it but it does not launch same as yours. I see the logo then the windows PING sound and then nothing. i have been in touch with coustomer support who havent been able to solve it yet and Ubisoft support that hasnt even bothered to reply after over a week.
I tried verifying the game files as well as reinstalling. nothing helps.

04-24-2016, 01:29 PM

looks like UPlay needs to be reinstalled, have you tried to download and reinstall UPlay from http://www.uplay.com?

best way is to take a backup from your current UPlay folder SINCE IT HAS SAVES FOR ALL GAME, uninstall and clean all traces, then download and install from the link above, note if you have other games installed, then you need to backup registry key as UPlay will not recognize that they are installed if you re-installed it.