PDA

View Full Version : Game crash with white rectangle and black background



GoverLyder68
03-26-2016, 01:11 AM
Hello,
My game was working yesterday, but without any reason this evening there is no way to launch it... There is a white rectangle on a black screen and my cursor.... I have to force to close the game...

I tried a lot of things :
- Restart the PC
- Check the files with Uplay
- reinstate the game
- launch in admin

.....

Please help :'(

OverTheClock
03-26-2016, 01:48 PM
Hello,
the same here. (And tried the same things to solve the problem.)

Since today the game starts with blackscreen. After few seconds Window10 shows an error message.
See: http://screencast.com/t/8trXFPWw

The past two days all was working well.

OverTheClock
03-26-2016, 02:43 PM
i found a log file (UGCErrorsLog.txt) in Documents/Trackmania Turbo folder

with following contents:
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/SUI.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\SUI.dds' not found.
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/ITA.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\ITA.dds' not found.
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/POR.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\POR.dds' not found.
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/AFG.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\AFG.dds' not found.
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/FRA.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\FRA.dds' not found.
<manialink> file://Media/Manialinks/Nadeo/TMConsole/Images/Helmets/Drapeaux/NewFlag/CHI.dds: File 'Manialinks\Nadeo\TMConsole\Images\Helmets\Drapeau x\NewFlag\............
.....

Xcell_Miguel
03-26-2016, 03:38 PM
It's not a crash, just wait, the game is scanning its own files and some old TM files.

Mine take about 30-60 sec to launch because it scans all my old TrackMania United and ManiaPlanet folders, for nothing, maybe old checks still in the game.

FYI, "something.exe does not respond" does not mean it crashed, it just mean that Windows can't have a response from this process when it pings it, most of the time it's just that the process is taking too long to respond, in some other cases the process is crashed and will never respond.

Wait and watch HDD utilisation, in that case it's because it scans folders, just wait.

RoamingKeating
03-26-2016, 04:13 PM
When I try to start the game I also see the white rectangle and a black background. But than it get's worse in seconds, the whole PC reboots automatically after that.
WTF is going on. We need an urgent fix for this!

owN77
03-26-2016, 08:59 PM
Hello, i got the exact same Problem.

OverTheClock
03-27-2016, 08:37 AM
I have found the problem in my case.
The game does not start if the Nvidia Shield Controller is connected via USB. I use the PC only for charge, but if the Shield TV is turned off the controller does connect as mouse with windows. Then Trackmania Turbo does not start anymore.

So, try to disconnect all gamepads and start the game.

(Have this cross posted here: https://forum.maniaplanet.com/viewtopic.php?f=524&t=37656&p=265590)

Slipdrum
03-27-2016, 01:13 PM
I have the same problem: Black screen with white rectangle.

I have tried everything that is stated on the internet so far to fix this problem, including:
- reinstalling GPU drivers
- fixing directX (all versions)
- run game as admin through steam (it won't launch without steam)
- check file intergrity with steam
- reinstalling the game (and deleting ALL local files)

It seems that this problem has appeared since yesterday with a lot of people, maybe it is because of a game- or Uplay update?

Edit: i know what is causing the black screen and white rectangle. The guy who previously posted about the gamepads is right!
The problem began when i unplugged the controller when the game was still on. After that my mouse would act weird and the PC made clicking noises when the mouse moved over the screen, also there was a large amount of lag and stutter in the mouse pointer and i could not click anything anymore.
I had to hard reset the PC before the mouse would act normal again.
This just happened again when i read the gamepad post. I unplugged the gamepad after the game crashed and i killed it using task manager, after the game closed i unplugged the gamepad and the mouse started acting weird again. Hard to hard reset the PC.

Edit #2: I just found out that the actual cause is the addition of a second controller.
I just started the game without a gamepad in the PC and it started fine, then i inserted the gamepad and everything worked fine.
However, the game crashed after i inserted a second gamepad because i wanted to test out split screen racing.
So there you have it.
Maybe it is because i use two different controllers? Can't test that because i have only two. I use one xbox 360 controller and an Xbox one elite controller.

Edit #3: with only the Xbox one elite controller in the PC the game starts up fine.
with only the Xbox 360 controller, the game also works fine.
However, the mouse started acting weird again when i removed the xbox one elite controller to test the xbox 360 controller and i had to hard reset my PC again.

Edit #4: The problem with the mouse also occurs after unplugging and inplugging the same controller in windows after the game has closed.

My conclusion is that this is a problem of communication between the game and gamepads. That's a shame becasue i mostly bought this game because i wanted to test out split screen racing with my friends

owN77
03-27-2016, 02:34 PM
Yes when i unplug the Gamepad the game works... Thank You @OverTheClock.