PDA

View Full Version : PC Stuck at connecting screen



BiggieFrog
03-21-2016, 12:18 AM
I've owned game since launch and haven't had any issues. Today when I try to play it starts normally and eventually gets to the connecting screen. It then sits there for about 30 seconds and then goes to a still shot of the division logo and says press space to start. I press space and it starts connecting again and, usually, gives me the Delta error. I just got the Romeo error for the first time a few minutes ago. On some occasions it goes back to the division logo and says press space to start.

Things I've tried:
- Disabling software firewall.
- Exiting software firewall.
- Bypassing my asus router and connecting the modem directly to my computer
- flushing DNS and changing DNS to google
- Disabling anti-virus software
- Exiting anti-virus software
- Deleted everything in my documents
- Microsoft host file fix

Edit: added several new things I've tried. Now getting Romeo error consistently it seems.

BiggieFrog
03-22-2016, 01:20 AM
I don't think my error is related to the backpack bug. I never crafted a backpack. Is there anyone else that simply cannot connect anymore but everything was fine for the first week or so?