PDA

View Full Version : PC Uplay keeps asking for product activation key



HSEOfficer
03-20-2016, 02:26 PM
Hello,

I bought the game on STEAM (Pre-Order) i've only manage to come and install it.

Once installed i tried to run it.

Ask for the Activation Key and enter in. The game is now on UPLAY GAME LIBRARY.

Tried activated on both STEAM & UPLAY and still keeps asking for Activation Key

After entering the Activation Key it says to run it on uplay - I DID IT but it doesn't work.

Now i can't even play it.

I even tried re-installing the UPLAY software with not success.

Any Solutions? Fix the Bug fast. :mad:

Vaypur
03-20-2016, 07:42 PM
I am in the exact same boat as you. I have tried fresh installs, uninstalling UPlay, making sure UPlay is closed an launching it through steam and nothing. I placed a ticket on 3/12/2016. They have not responded. I have added images of what I am talking about and asked twice if anyone is going to help me. I went to do a live chat this morning and the button magically does not exist for me to click on. Pretty pathetic that I can't get an answer from a ticket I placed over a week ago. Best part is, a couple of my friends purchased it AFTER me and they do not have this problem. If I ever hear anything back, and I plan on calling them tomorrow morning, I will post back here to let you know what the fix was.

*Edit* Called them this morning. They do NOT provide support over the phone unless it's for not being able to access your Uplay account. They directed me to the website to start a live chat, which I have yet to find. They have yet to reply to my ticket.