PDA

View Full Version : BUG FOUND: Weapon mod forced deactivation



Troutmagnet
03-09-2016, 09:57 PM
Hi there Ubisofters,

I found a bug last night (March 8, 2016) playing The Division on PS4. This is after the latest launch patch.

Here's how I found it:

- Primary weapon is a Classic AK47. Secondary weapon is a marksman rifle (M21).

- I found two 12X Scope mods on two separate occasions (both drops).

- I applied one scope mod to a rifle I no longer used but held in my inventory, but left attached.

- I attached the new 12 x scope mod to my active M21 in my secondary weapon slot.

- I aimed the M21 and the scope would work. The second attempt after the first attempt, the scope on the rifle reacted as though the scope was not active.

- After re-checking the weapon mod menu, the scope was removed. I reapplied it and tested. It worked. The second attempt to use it it was not there again.

This would keep happening until I applied the first 12x scope I found to the M21, removing it from the previous weapon. After I did that the problem went away.

Incidentally, just to see, I applied the second (newer) scope to the other weapon I removed the scope from and the problem did not happen.

Great game, BTW. Enjoying it so far.

tactical_ghost77
03-10-2016, 11:50 PM
This happened to me as well with the M44, the way I found a fix is try attaching a diff scope use it for a few shots then install the 12x scope. Hope this works for you

Kalvorax
03-11-2016, 03:22 PM
so it seems that swapping any scope would 'fix' the bug? or only the high-powered scopes? (just crafted a classic m4 carbine and having the issue you described with the stock scope.)

That being said, I am on PC. though from what I've found the bug is across all platforms.

Ubi-Houck
03-11-2016, 04:07 PM
Hello,

We have reported this issue to the development team, thank you for taking the time to report it.

Thanks