PDA

View Full Version : Automatically shooting in game



Datric
03-08-2016, 02:08 PM
So after about 15 minutes of continuously loading the game I finally got it loaded. (Was constantly just getting a black screen)

The menu began to glitch out almost like there were competing peripherals. I figured that was no big deal and tried to continue with the mouse. I could highlight options (This took quite a few tries to actually get the item selected) but couldn't click or double click to move forward. I chalked this up to the design and hit enter to continue.

The main problem;

I haven't played this game or ran the game from the beginning so I don't really know what to expect in terms of actions within the game, but my character just walks slowly when I press forward (W) and CONTINUOUSLY shoots. It's acting as if I have the left mouse button held down. When I move forward to try other actions, the health bar and other items seem to stutter or glitch out like the menu does. This game in it's current state for me is unplayable.

I am fairly tech savvy so after reading forums and suggestions, I unplugged/removed any and all controller hardware from my computer. After that didn't work, I tried;

1) Removing Razer software (Synapse)
2) Removing ALL drivers related to the controllers
3) Rebooting
4) Unplugged BOTH my keyboard and mouse, using just the controller
5) Attempting to reset everything to factory default. (It already was since I can't really do much)


Despite all the things I tried, my character still just continuously shoots in game. The controller alone (with the keyboard and mouse unplugged) did let me "take cover" but I was still continuously shooting/ Help?

Ubi-Stature
03-08-2016, 02:16 PM
Hi there, Datric,

Welcome to the forums!

Are you using any Logitech peripherals?

Datric
03-08-2016, 02:27 PM
I am using a Razer Deathadder 3.5G Black and a Razer Anansi keyboard.
I do however have a Logitech dual shock controller that hasn't been plugged in for weeks.

Ubi-Stature
03-08-2016, 02:28 PM
If your keyboard is an LED keyboard can you try disabling the backlight?

This has resolved a few issues for other users with similar problems today.

Datric
03-08-2016, 02:31 PM
I tried that also. My keyboard has 2 usb plugs. One for the keyboard and another for the backlight. I tried it without the backlight one plugged in and it was a no go. Also the issue persisted when the keyboard wasn't plugged in at all.

Datric
03-10-2016, 02:14 PM
I fixed this by reinstalling the OS. There must have been some ghost drivers/controller problem. After installing the OS I immediately noticed that the menus worked fine (I could double click with the mouse), there were no controller buttons on the screen (the keys changed), and I didn't automatically start shooting when I went into the game.