PDA

View Full Version : Update won't download?



Lief_Ericson701
02-19-2016, 05:54 AM
Waiting for an update (after the big one, don't know number, should be most recent?) but uplay says that i can't download, and that i should check that i have enough memory and that i have an internet connection. Nothing has changed about my internet between my most recent attempt and this post, and i have 28 gigs of storage on my comp, plus 3 hundred gigs on an external hard drive. What's the deal? Anyone else having this prob? Solution?

Tldr; game wont update, ubi not helpful

Despot-SRB-
04-07-2016, 07:56 AM
Have you find any way to fix that problem. Same thing unfortunately happend to me and they not even responding to my tickets.

motorbikera2012
04-08-2016, 03:29 PM
I got the same problem, it says unable to conncet to ubisoft server and ask me to check internet connection and hard disk space when I tried update download. I tried again and again in several days but all the same.
I found it happened to many other players from other forums, but didn't got any news or reminds from ubisoft. Now only can play the game in offline, but couldn't save anything in after. So sad.

Draekon666
04-09-2016, 04:17 AM
Just got it to work. I first verified the game files which found some corrupt files. After it redownloaded those, it was able to download the new update. gl