View Full Version : This is really starting to grind my gears...

01-05-2016, 05:11 PM
**I have made a few edits at the bottom. Please read if you have time, I appreciate not everybody can be bothered to read longer posts.

Here's what happens exactly;

- Open Steam and UPlay.
- Minimise UPlay.
- Open Steam back up and hit 'Play' to launch the game.
- Steam reads 'Running...' next to the AC icon.
- After a few seconds, the screen will flash.
- Steam no longer reads 'Running...' next to the AC icon.
- Move Steam's window over a bit and open UPlay back up again.
- Attempt to launch the game through UPlay.
- Steam reads 'Running...' next to the AC icon.
- After a few seconds, the screen will flash.
- Steam no longer reads 'Running...' next to the AC icon.

No activity in Task Manager either.

PC specs as follows;

- ASUS X99a
- Intel Core i7 5820k @ 3.9GHz
- 16GB DDR4 @ 2400MHz
- Palit GTX 980 Jetstream

- Running Windows 10 (build 10586)

- Game is installed on my D:/ drive

I upgraded from Windows 8.1 to 10. AC was working flawlessly on 8.1.

I tried verifying the cache. Doesn't work.
I tried a clean install of drivers. Doesn't work.
I tried a clean install of the game. Doesn't work.
I tried disabling my overclocks. Doesn't work.
I tried setting UPlay and the Game's .exe to run as admin. Doesn't work.
I tried setting ESET NOD32 to gamer mode. Doesn't work.
I tried turning NOD32 off altogether... Guess what? Doesn't work.

I'm stumped... any suggestions?

I must have about 15-20 hours of play time on my account too so it's not like I can even apply for a refund for a product that no longer works as it should due to an issue nobody knew about.



STEP1: Look for the above app files in Ubisoft's Uplay programme folder and set them to run as admin by right-clicking their .exe/.app icons and navigating to compatibility.

STEP2: Then open up steam and navigate to 'browse local files' of AC:S. Then in that folder you need to set...

-ACS.exe (or it might just read ACS and the file type will read 'App')

... to run as admin too.

You should be set after that but you may need to reinstall or verify game cache and repeat step 2.

This fixed it for me. I didn't look for the Uplay launcher in the AC:S folder.


But now I crash on the main menu/when trying to start a new game every single time. FFS ♥♥♥♥ING AAAAAAARRRGH.


Also, I get no error messages when the crash happens. All I get from Ubisoft is along the lines of "Ever so sorry, but none of our games officially support Windows 10". Has anybody attempted a work-around?

**I also posted this thread on Steam to try to find a solution but to no avail so far. It has been working perfectly last time I loaded it up. Just don't get it.

01-05-2016, 05:50 PM
Fixed it. RTSS interferes with the game EVEN IN STEALTH MODE. It's not enough just to turn the on-screen display off, you MUST close it entirely.

01-05-2016, 10:03 PM
Set detection level to low and Custom Direct3D support to off and it should not crash while RTSS is on.

however, this point is mentioned in the following thread, if you encountered any future problems (hopefully not), then check it out :)