View Full Version : Why do so many UPlay Games fail to start?

12-31-2015, 04:44 PM
So I have 23 UPlay games (Two I bought Twice [different versions]) and many of them through Steam..... BUT most of them dont work.

AC Creed Unity Works Great

AC Syndicate Works Great

Far Cry 4 Works Great

AC 2 gives me the middle finger.

AC Brotherhood gives me the middle finger.

Far Cry 3 gives me the middle finger.

They are all installed on top quality hardware... and have tried all the fixes that hundreds/thousands of other players having similar problems have tired......

.... but mine dont work..

Is a chimp working at UPlay or is is Chimps who made my $4,000 PC rig?

01-01-2016, 03:15 AM
What error does they give, m8 ?

01-02-2016, 08:50 AM
can you be a little more informative about what error did it gave you ? i can run them just fine with the same specs, your specs doesn't mean anything if its configured wrongly.

01-07-2016, 06:05 PM
AC:R faled to start for me, I had to try several times to launch it properly every time. Fixed it by re-installing it (wainting through that god-awful long install of DirectX)

01-08-2016, 07:18 AM
I don't share the same amount of Ubisoft games you have in Steam and Uplay but most of the games that I do have in Uplay, I never ever had a single problem with it. Maybe you could try launching it and give us the error you get - I am sure someone would be able to help.

01-12-2016, 01:50 PM
Nobody cares about your "rig" price, seriously (mine is better and |I dont announce it to everybody).
One of my friends (no really, it wasnt me) had a very similar problem after trying a... "free trial edition" of one of the Uplay games. He ended up resetting the whole windows install to fix that.