PDA

View Full Version : Playing GR on 2 Comps witha router



XyZspineZyX
08-24-2003, 02:08 PM
Today i went to play GR with another person from my family. There are 2 computers, and they both have cable split be a router. I had created a game on one computer, and when i tried to access it from the other computer all it did was stay at the screen when accessing the server. After a while i had hit cancle. So what shout i do so i can host a game on 1 comp and another persdon and play on my game on the other

XyZspineZyX
08-24-2003, 02:08 PM
Today i went to play GR with another person from my family. There are 2 computers, and they both have cable split be a router. I had created a game on one computer, and when i tried to access it from the other computer all it did was stay at the screen when accessing the server. After a while i had hit cancle. So what shout i do so i can host a game on 1 comp and another persdon and play on my game on the other

XyZspineZyX
08-24-2003, 03:33 PM
To ScHu-


If you have a firewall / router on your system, make sure that the correct ports are open for the game you are trying to play.

If you are using Windows XP, please make sure that the default firewall is disabled. (Please refer to your Windows XP documentation on how to disable this feature).

If you are on a network(LAN), please make sure that the game knows which IP address must be used. Most games have an IP selection tool in the options menu. Also, make sure that ubi.com is set to External IP adress (In the general options on ubi.com).

In ubi.com, to change between IP addresses, you need to open the Lobby then go into Options then General Settings. Under 'ubi.com settings', you will be able to choose between Internal and External IP address.

Internal: To play on LAN
External: To play on Internet

Ghost Recon requires: Ports 2346, 2347, 2348

Ubi.com requires: Ports 80, 6667, 40000-42000



Message Edited on 08/25/0301:41AM by snipe21

XyZspineZyX
08-24-2003, 05:04 PM
Yea, my computers are like that. The one on XP has the server on it right now, but whne the othere computer (98) tryes to get into it it just stays on the connectig screen............. i changes ports but still does not help?????

XyZspineZyX
08-26-2003, 08:30 AM
ScHu,

Are you trying to host a LAN game or over the internet?

If over the internet you have to forward ports 2346, 2347, 2348 to the host (IP adress) so that people joining can pass the router to the host.

If over LAN, you dont need to play around with port settings. First thing is to check both computers are comunicating over the LAN.
I you havent done this already use 'set up home or small office network' wizard in XP. XP will then promp you to make a set up disk that you run in your windows 98 machine to setup the network.

Once both computers are talking (you can see each others pc's on each computer) then you can join.

Also check that router is set to act as DHCP server as you may be getting conflicting IP addresses (one machine is 10.0.0.0 & other machine is 269.243.000) check this by running ipconfig at the dos prompt on each comp.

Hope that helps

Mortley

XyZspineZyX
08-26-2003, 04:08 PM
No not a lan game just a regular internet game. I did what u said but nothing..........I dont get it??? All my stuf should work but it does not??????

XyZspineZyX
08-26-2003, 08:37 PM
Some of this may be a repetition of what has been said but anyway:

Concentrate on the host PC (XP) - leave the guest PC (Win 98) as is.

In the router setup of the host PC you forward the ports 2346 - 2348.
Make sure that these ports are forwarded to the internal IP address of your PC. You may wish to make that one static to avoid connection probs next time. You do this in the tcp/ip properties and need the subnet mask and primary/secundary DNS server. If you don't have these, you can get them from your ISP, probably even from their website>support.

So in the dos prompt - as mortley says - type ipconfig or ipconfig /all and make a note of your IP address. This one must correspond to the one in the router setup under forwarding of ports.

Router setup: If you have an option called "Filters" and a submenue called "Block WAN request", you should disable that one.

So much for the router.

Game>Options>Multiplayer: check "behind firewall". You must do this every time. The box is unchecked when you exit the game.

Game>Multiplayer>create game........and wait.

Win 98 PC: Needs your external IP. If you don't have a static one, download the freeware program "mywanIP" from http://www.mywanip.com (link at the bottom of the site).

Tell the win98 PC this IP address.

Win98 PC: Game>Multiplayer>Internet. Replace the zeroes left bottom with your external IP address.
The XP host should now show up and then the Win98 clicks "join game".

I think /i/smilies/16x16_smiley-happy.gif



http://home20.inet.tele.dk/famjourdan/GRsig.jpg


Message Edited on 08/26/0308:39PM by GreyHaired