View Full Version : Division Alpha Forum: no permissions?

Spike Hawkin
12-09-2015, 10:49 AM
I am in the Alpha right now, i have found something worth giving feedback on, and i tried going to the Alpha Forum but was told i do not have permission to participate. what gives? (also why have a Technical Support forum if no one is allowed to post?)

The Hanz
12-09-2015, 11:53 AM
I'm trying to submit something I think is worth noting and aren't granted permissions either.

12-09-2015, 11:55 AM
I am having same issue as well as its not letting me connect to the game

12-09-2015, 12:17 PM
same issue here.

12-09-2015, 12:27 PM
I'm the same, cannot access Alpha forums although I'm part of the Alpha. Not tried the game yet cause I'm stuck at sodding work :(

12-09-2015, 03:50 PM
Same issue here

12-09-2015, 05:38 PM
I am currently playing the alpha myself and denied forum access, I'd like to gain access to report, and read others feedback

GS Sprayed
12-09-2015, 06:01 PM
Same here. I've contacted support. Hopefully I hear a reply soon

12-09-2015, 07:17 PM
I'm having the same issues. Trying to give some feedback but it's not letting me enter.

12-09-2015, 07:40 PM
Same here.

12-09-2015, 07:51 PM
Same here

Sippi Kid
12-09-2015, 08:00 PM
No access to forums.

12-09-2015, 08:13 PM
It's giving me a error message and would not let me start the game. After I quit out I did get it to boot up.

The Toe Cutter
12-09-2015, 08:14 PM
Where are the forums for the Alpha?

O MaKaVeLi O1
12-09-2015, 08:23 PM
I have the alpha but can't get into the forums.

12-09-2015, 08:39 PM
Hey there, still having issues trying to access the alpha forum, issues have occurred. Anyone managed to access it yet to leave feedback etc?

12-09-2015, 09:58 PM
Same and was just playing got booted then locked from game

PsK Sych3
12-09-2015, 10:52 PM
Still the first couple of days of the alpha, play a bit more and be patient. I'm sure it takes some time for the forums to register those who have played as alpha testers.

Sasquatch Sim
12-09-2015, 10:58 PM
Not just me, good to know

12-09-2015, 11:51 PM
So i have redeem my code for the alpha play and but im getting nothing to download the game contact microsoft but they be like uplay has to fix it not us... So i try going here but i dont have permission to some of these forums wtf? so how am i to get help if im not allowed to contact those i need help with to just download the game so i can begin playing?

12-10-2015, 12:25 AM

12-10-2015, 01:55 AM
Yep still not working, very disappointed at Ubisoft, they can't even get a forum to work right! I've got some problems with the game that I believe should be brought up but it's not working and I'm probably going to forget about it. If you're going to want feedback for your game then you should put it IN the alpha! When I have to go to a forum and post something on that it just tells me that they don't really care what you have to say because the game is going to stay how it is and my feedback will be drowned in all the others, never to be read!

12-10-2015, 05:39 AM
same here. no access

12-10-2015, 06:34 AM
Having same issue of not being able to access/post in The Division alpha forum. I've only come across a couple minor technical issues in game, but still things worth reporting.

12-10-2015, 08:57 AM
I redeemed the code via the XboxLive website (while my Xbox wasn't on) and I am not seeing any option to download the alpha or any indication that it will download automatically.

Oh, and I also cannot access the Alpha forum...

12-10-2015, 09:41 AM
Don't have access to alpha forums. Would like to make some posts

12-10-2015, 09:58 AM
I got to level 6 before it dropped me, and now my Xbox won't let me open anything. It keeps saying, "Having trouble connecting to Xbox Severs". It's driving me insane!! Something has to be going on with Xbox itself, anyone else having these problems?

12-10-2015, 10:19 AM
Hi there,

Sorry for answering this thread so late.
To access the Alpha forums, you first need to log into the game and accept the NDA. There is then a delay of 30 minutes to 1h after which you will be able to access the forums.
If you still get the message that you don’t have permissions, please just log out and back into the forums.

See you there!

12-10-2015, 10:34 AM
That's all well and good, but can't even seem to successfully initiate download of the launcher after redeeming my code via the Xbox website.