View Full Version : Black Flag REFUSES to save

12-03-2015, 08:52 AM
I played the other day for almost 5 hours, and then okay, it's been autosaving all day, I'll quit, fun game, whatever.

I go back, no save file! Oh, wow, that really is annoying, I will look it up. Oh, it's a common issue? Okay, well, that's just bad luck I guess. I'll read the solutions, try them, then be on my way. So I turned off the god awful cloud enabling bogus that they push on us, so I can save it offline now, and then just in a local file, and copy it. Sounds good!

So I'm playing, I get about four hours in, not very fun repeating the same stuff by the way, and then go okay, I'll copy the local file!

It's not there? What?

I go to C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher and there is no savegames folder. None. So I don't close the game, start to panic, let's see what we can do... Turn the thing back on, no dice, turn it off, no dice...

Lost it all AGAIN.

So I go okay this is really stupid now, let's just start the game, for about 15 seconds, it does an autosave, okay, if I just exit to main menu it's there, but there's STILL no local file. And then if I close uplay, then reopen it, WELL WOULD YOU LOOK AT THAT, NO SAVE FILE.

If this doesn't get fixed, Black Flag will be my first and last Ubisoft purchase. I get ONE NIGHT to play. It's not a common thing for me. I worked my face off to have the time to enjoy myself, and I had to spend it replaying content I just paid for, and now I'll have to do it A THIRD TIME. And something tells me I'm not looking forward to it! That's right, maybe in three weeks when I have free time again, I MIGHT SPEND IT ON SOMETHING THAT PERFORMS AT THE BASIC LEVEL IT SHOULD.

This is beyond ridiculous.

12-03-2015, 10:51 AM

it seems a permission to write to disk problem, have you tried to run UPlay and Game as Administrator?

if it didnt work, please download latest UPlay from www.uplay.com (http://www.uplay.com) and reinstall and run it as Admin.

P.S: Cloud saves sync is disabled for AC:BF, so even if its enabled in UPlay, saves will not be synced with the cloud.

12-03-2015, 11:41 PM
Okay, so I tried that, and did some tests, and running as administrator works for saving. That works, thanks for your advice. althoughIhavenoideawhyitwon'tjustsaveNORMALLYbutwh atever...

However, now there's a new, minor problem. See, a lot of keys on my keyboard are broken, so I run AHK (autohotkey) to work around it. I can't use p, so I use the left-side bracket, and I can't use backspace, so I use pausebreak, and all of my numbers are broken as well... Well normally AHK can run during the game, but it seems since running Black Flag as administrator is an elevated process, I can't use a lot of my keys anymore.

I can change a lot of the keys in the options menu, and I already have done so, but the thing is, I actually can't change all of them. For example, when you see a sight on the ocean, you can press 2 to see it, but if you look in the options, there is no way to change 2 into any other key. I also tried in game, for some reason the NUM pad doesn't work for stuff like that, either.

Is there any way I can change key bindings for keys that are not listed in the options menu, but are still in the game?

In any case, thanks for telling me about that. I'll run as Administrator when I have time to play in the future...

12-04-2015, 01:10 AM
Unfortunately those keys are not re-bindable, however, you can always get a cheap keyboard, it only costs 5-10$ and doesnt worth the trouble playing with half broken one.

12-04-2015, 03:10 AM
Welcome to a ubisoft game where we alhpa test 1 month after release.

12-05-2015, 02:04 AM
OP sorry to hear of your problems but stick with it, BF is a great game.

I seem to remember making sure I fast travelled a lot in BF to force saves. So when you complete an action Fast Travel somewhere to make sure the game saves.