PDA

View Full Version : PC Can't update Far Cry 4, progress bar doesn't move



Spaniel101
11-27-2015, 06:57 AM
Hi Guys,

So for the past day and a half, I've been trying to update Far Cry 4. I've just recently installed it so it needs to patch to version 1.9.0. The problem is that when the patch starts to download, the progress bar doesn't move and the download speed stays at 0 B/s. I know Uplay is transferring data but for some reason, the patch just doesn't want to download. I've even left the "download" overnight hoping that it will sort itself out, but it hasn't (5.24 MB in 6 hours). Please help...

I've included two screenshots.

http://imgur.com/itAyCP8

http://imgur.com/YiXWsc4

WID992007
11-27-2015, 05:24 PM
did you buy the game via Steam or just Uplay ? (if you bought it via steam .. that's where your updates come from)

(and the current version is not 1.9.0 its 1.10.0 )

did you purchase the digital version or the boxed DVD version ?

have you tried to Set either or both Steam and Uplay to
Run As Administrator ?

have you tried the solutions mentioned here ?
https://support.ubi.com/en-US/FAQ/9/3888/trouble-downloading-via-uplay-pc-client/kA030000000edgsCAA