View Full Version : Mouse Problems

11-25-2015, 11:21 AM
Sorry pleace see the movie

Can you please help me answer this question it


11-25-2015, 11:24 AM
Hi there, RabbitArmy,

Thank you for reporting this issue.

Have you tried disabling the Uplay in-game overlay from the Settings menu of the Uplay Client?

11-25-2015, 12:19 PM
Thanks~~~I can play

11-25-2015, 05:39 PM
Have a same problem, but disabling Uplay overlay does not help...

11-25-2015, 05:48 PM
Hi there, manchking,

Welcome to the forums.

Have you tried removing all other USB peripherals that are not needed to play the game?

This will help avoid conflicts with the mouse in game.

Can you also confirm if your graphics drivers are up to date?


11-25-2015, 07:01 PM
Hi, thanks!
I remove all usb peripherals and ps2 keyboard but problem still exist.

Nvidia GTX660 Driver version 359.00 but problem was yesterday too at an earlier driver.

11-26-2015, 10:29 AM
Sorry my question has emerged

11-26-2015, 10:56 AM
Hello All,

I would try the following steps to disable pointer trails as they have been known to cause the loss of cursor in games on some peoples computer

Can you open the Control Panel?
From here can you then navigate to Mouse and select the Pointer Options tab
From this screen can you uncheck the Display pointer trails box

11-26-2015, 05:09 PM
Ubi-Talos, I have this checbox uncheck by default.

11-26-2015, 06:42 PM
Hello manchking,

If you are able to can you change display settings in game and set the game to run in a Windowed or borderless mode and see if the cursor appears then?

11-26-2015, 08:10 PM
Actually cursor is here...


11-27-2015, 01:02 PM
same Probleme here,
I'm seeing the windows mouse cursor from the early start, also on the "'Nvidia how it's meant to be played" screen and the intro clip !
i think this is not meant to be.

it's not possible to change to windowed mode through with mouse navigation its not reachable with the "flipping" buttons. is there a chance toggleing windowed mode through config files ?

11-27-2015, 01:45 PM
Hello manchking

Thank you for the video showing the issue could you right click on a clear part of your desktop from there choose the option Personalize, then in the new Window can you then select DISPLAY.
In this screen can you make sure that it has been set to Smaller - 100%(default) if this has not been set to that value already.


Can you try the following steps to modify the config file
C:\User\?????\Documents\My Games\Rainbow Six - Siege"Unique Uplay ID"

From here can you open the file GameSettings.ini in Notepad.
From Notepad can you look for the line WindowMode=0
You will just need to change the 0 to 1 for Windowed or 2 for Borderless.
Save the changes and launch the game again.

11-27-2015, 02:40 PM
sorry, this does'nt solve the problem, in windowed and borderless stay's the same problem

11-27-2015, 03:14 PM

Thanks for the update, can you try what I suggested for manchking

11-27-2015, 03:24 PM
it's set to "smaller 100%" i didn't had to change it.

11-27-2015, 03:37 PM
hi! I have same problem

anyone knows how to fix this bug?

11-27-2015, 04:13 PM
Ubi-Talos, it's set to smaller by default.

11-27-2015, 06:04 PM
Hello All,

Thanks for the update, can you follow the guide from Microsoft in this link (https://support.microsoft.com/en-us/kb/929135) and try a clean boot of the computer to simply rule out conflict with background applications.

11-27-2015, 06:48 PM
Hello All,

Thanks for the update, can you follow the guide from Microsoft in this link (https://support.microsoft.com/en-us/kb/929135) and try a clean boot of the computer to simply rule out conflict with background applications.

thanks but the problem is not solved

11-27-2015, 06:56 PM
If you are still experiencing this issue after trying previous steps.

Can you please create a support ticket on the Support Site (https://support.ubi.com/), we would need some information of the computer you are trying to play the game on. The steps below will guide you on how to use two windows programs to collect the required information.

The first program is Direct diagnostic Utility this will provide information on the hardware of the computer and driver information.

- On the keyboard hold down the Windows key on the keyboard and press "R".
- Type "dxdiag" and click OK.
- This will open the DirectX Diagnostic Tool.
- Click the Save All Information button at the bottom.
- Save the file to your Desktop with the name "dxdiag.txt".
- Can you please attach the file to this question through the support website?

The second program is System information (MSINFO)

- Hold down the Windows key on the keyboard and press "R".
- Type "MSINFO32” (without quotes please) and then click OK
- Click OK.
- When the program loads from the menu bar can you - Hold down the Windows key on the keyboard and press "R".
-Once the program has loaded from the menu bar click File > then EXPORT (not save) the file locally to your system, make sure the Save type has been changed from nfo to text file before saving.
Again please attach the file that has been created to this question.
*If the file is over 5MB in size you will need to use a file compression folder such as 7zip or WinRAR to compress the file under the 5MB

After you have created the ticket with the requested information can you provide me with your case number

11-28-2015, 04:02 PM
I have same issue with select any option with the mouse.

I hope that final game version is fixed.

Thank you very much.

11-28-2015, 07:28 PM
I encounter the same problem since the closed beta :(

12-01-2015, 10:52 AM
anyone knows how to fix this bug?

12-02-2015, 11:08 AM
After the release i have the same Problem !
game is unplayable...

12-02-2015, 02:00 PM
Currently I have solved this bug!!

In the mený of game, press SHIFT + F2.

now, in uplay mený, press esc and returno to game.

Oddly enough, the game doing this to me works

[sorry for my english]

12-09-2015, 10:56 PM
Just to echo what others are saying, my install seems to think that my USB joystick is controlling the game. So my mouse does not show up on the screen. If I left click my mouse I can see the pointer. I let go of the mouse button and guess about where the pointer should be and the clicking still works. But in game it is all confused. Unplugging my USB Joystick set up really is not an option as I use it often for flight sims.

I cannot seem to find and options page which will let me set the graphics, keyboard controls etc.