View Full Version : Can't install Might and Magic 8 (Windows XP etc) on Windows 8.1

11-16-2015, 07:50 PM
I have a Windows 8.1... I've been trying for hours to install this game, downloading different files it says I'm missing (SWFLASH.OCX etc).

I have it on disc form, the sold-out software version, and I'm trying to run the Setup.exe files straight from the disc, not autorunning. Straight away I get an error saying:

"The procedure entry point AppCacheLookup could not be located in the dynamic link library C:\Windows\SYSTEM32\urlmon.dll."

I've tried to look up what this means, and I have no idea.

It DID go through a whole couple of hours telling me I didn't have Macromedia Shockwave 8, and I downloaded from the Adobe site something which said it was the same thing. Since then it's stopped giving me that error message, but now it's giving me a new one:

"Run-time error '339':
Component 'SWFLASH.OCX' not correctly registered: file missing or invalid"

The first time I got this message I downloaded this file from somewhere, and put it in the System32 folder (I then tried it in the SysWOW64 folder?? My laptop is 64-bit) but I'm still getting the error message :( I'm now doing a system file scan, as suggested by the Microsoft site on a thread made by someone else.

I'm so stuck!! I'm not the most tech savvy person at all, as you can tell... Please can someone help??

11-16-2015, 10:16 PM
Well, going by my experience from installing 'Might and Magic' games on a Windows 7 PC, I would suspect that the installer just does not want to play nice with your newer Windows 8.1?

I would try the standard 'Run as administrator, install in compatibility mode' and see if the installer gets any further.

You might want to check the STEAM forums for the game, and see if there are any patches/newer installer available for Windows 8.1 as well. I however cannot stress enough not installing the game under STEAM. From what I hear, UBI refuses to disable their software online guard for STEAM installs, and STEAM's online software fights with it like cats and dogs. Many people report they cannot even get the newer Might and Magic to start, let alone run under STEAM.

As a final note, you had actually posted this on the 'Mighty Quest' forum, not the 'Might and Magic' one. You have probably picked the very worst of wrong forums to post to, as 'Mighty Quest' is basically abandon-ware for the last 4+ Months, and there is no longer any UBI staff associated with this game, or moderators active on this section of the UBI forum..