View Full Version : Project: the dam building part 5 of 6 bug!!!!

11-04-2015, 08:40 AM
I have loaded 50 biopolymers and it shows as green, before i deliver the cargo to may tian, i went into another sector then back, now i cant deliver because when i move mouse over may tian it does nothing, i click and it doesnt deliver anything, im stuck on this part... please fix this bug soon.

11-04-2015, 08:51 AM
I have the same problem on two different missions.


Slowing down my gameplay I think. Really enjoying the game otherwise.

11-05-2015, 04:44 AM
does ubsoft ever reply or say something about this?

11-05-2015, 09:34 AM
does ubsoft ever reply or say something about this?
So far all we've gotten is "We were not aware of this issue and will look into it" so, don't get your hopes up. I can't see how they could possible not have encountered this, seeing how many people post about this exact same issue.

11-05-2015, 04:53 PM
Same Problem here...cant deliver the polymeres


11-19-2015, 01:26 AM
still not fixed, i cant build the dam.... after update still the same.

12-06-2015, 02:10 AM
Tired of waiting... gonna request a refund... this game is waste of money.

12-06-2015, 02:48 AM
Hi xfw55,

Do you still have your support ticket number?