PDA

View Full Version : I have changed nothing, and yet today it crashes every time



Bradenh1986
10-10-2015, 09:31 PM
Like the title says, I have made no changes whatsoever since playing last night. I am on map 2 of the Haven Campaign and have thus far completed the Dungeon and Sylvan Campaigns. Up until this point I have had no major issues. But when I try and load my game today (I have tried my main save as well as several autosaves) it simply goes to the loading screen then crashes after about 10 seconds and says "Might and Magic Heroes VII has stopped working" what could be going on here?

Adding the problem details

"Problem signature:
Problem Event Name: APPCRASH
Application Name: MMH7Game-Win64-Shipping.exe
Application Version: 1.0.12161.0
Application Timestamp: 5605bba5
Fault Module Name: MMH7Game-Win64-Shipping.exe
Fault Module Version: 1.0.12161.0
Fault Module Timestamp: 5605bba5
Exception Code: c0000005
Exception Offset: 0000000000cb6576
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0d06
Additional Information 2: 0d0697d9d24273c7a1dd2b14215a6d67
Additional Information 3: 6bc0
Additional Information 4: 6bc00dbded99a38b85409834995ea659"

victorash
10-11-2015, 05:42 AM
Maybe you didn't changed anything, but the Universe changed.
Taking things more seriously there is a known issue that the savegames get bugged. Also for me the gamefiles got corrupted without doing anything special. so here are some possible workarounds
- after pc restart try to pload previous savegames, other than autosaves, quick save or the last bugged save. Autosaves get bugs
- go to uplay, verify the game files, repair them if corrupted
- try reinstalling the game if not resolved.
- try playing offline
- Try to put graphic on low and see what happens, without vsync, etc. See if some option from there bugs your game
- try to play with no sound
- try to open game as admin,
- set manually the game compatibility for your windows version (right click on the gamelink, etc.)
- try playing in windowed mode
Of this doesn't work than start playingo ther map or wait like the many of us for the next week patch
Or gou cand always open a tech tiket
Good luck!

westyofoz
10-11-2015, 07:18 PM
Save game crashes for me as well. I tried most of those to no avail thanks for the attempt to help . Starting to feel like I am playing beta3

victorash
10-11-2015, 10:42 PM
It's funny, but I changed nothing and I was able to finish my first map without a single crash or high loading time. I think there are buggy skills, artifacts and other map content that corrupt the game and give the annoying infinite loading time, high ram usage and the rest of the game breaking bugs. So it's possible...

UBI-Froggard
10-14-2015, 11:06 AM
Hey Bradenh1986 weclome to the forums.

As victorash mentioned, there is a known issue with save games are taking a long time to load and/or crashing.

The dev team are working on getting this fixed as soon as possible and we will be sharing updates on a big patch that should resolve this as soon as we have more info. The fix for this is currently being tested to make sure it's safe.

@victorash - Thanks for your suggestions for Bradenh1986 and westyofoz to try

MadvalRock
10-14-2015, 04:45 PM
Nice. My game worked fine. Now since the patch everytime I launch my campaign it crash to desktop.

UBI-Froggard
10-15-2015, 02:33 PM
Nice. My game worked fine. Now since the patch everytime I launch my campaign it crash to desktop.

Hi MadvalRock,

I'm sorry to hear your game is crashing to the desktop.

Please could you try the verify files option to see if this resolves your issue?

In Uplay - Select "Properties" located underneath the "Play" button and then select "verify files"

In Steam - From the Library section, right-click on the game and select Properties from the menu. Select the Local files tab and click the Verify integrity of game cache.

Kind Regards,

oost1
10-15-2015, 04:25 PM
OS: Windows 10

After the patch 1.2 i tried to load several saved games, but none of them won't.
I verified the files.
I am sure that a memory issue is causing the crashes.
While loading a saved game the memory use becomes to high, in my case over 6 GB and the system gives te warning " out of memory"

kind regards

victorash
10-16-2015, 10:54 AM
for me the savegames that were bugged remained bugged. In my case I considered safer to have a fresh start of the map so that it won't carry previous-old bugs