View Full Version : Gloria bug 2nd mission of tomas

09-30-2015, 03:23 PM

I'm stuck at the end of the second mission.
After the betrayal of gloria, Tomas is blocked. I know I must free a fire elemental.
There is a fire elemental at save yes BUT when you double click on him nothing happens !! We can just gone your rounds and lose the mission ... I am not the only one with this bug:

See you this subject =>

See you sreenshoot =>

Kind regards :(

09-30-2015, 05:02 PM
There is like 4 threads already about it. Its a nasty bug, someone suggested replaying the mission and doing all the quests and explore everything before attempting gloria underground. I have not tried it yet couse i don't feel like i want to replay it again but u can give it a shot.

09-30-2015, 05:50 PM
Sorry for that, I go tried this solution

09-30-2015, 10:29 PM
When you get to the gate between the two lands you need to take all of Ymirl's troops, leaving nothing. She is then sent to a small area to the side of your castle and is no longer active in your party. Her portrait disappears from your screen and only Tomas' picture remains.. There is a brief animation that plays after this scene and the mission will continue properly. I had to replay the mission to get it to work.

10-01-2015, 09:18 AM
I don't think it is a question of troops, since I did it w/o troops and still I am not able to interact with the elemental.
However it might be linked to the quest to assign Ylmoril as governor? How do you assign her as governor? In garrison in the city?
The quest was not completed in my case which might cause the blocking...

10-01-2015, 09:31 AM
hey guys, i got the same bug. followed the quests properly, cleaned up the entire map.
I got stuck with the elemental ritual thing, plus when passing the turn it skips my turn until it ends with game over.
all my auto sav - quick save is already infected* with the bug, no other way but to restart the map from the start and hope somehow it does not occur again.

10-01-2015, 02:34 PM
Ymoril needs to be assigned as governor before progressing through the pass. Otherwise the later encounter with Gloria willl be bugged and leave you unable to complete the map. (at least that's how I got it to work on the second attempt - required a complete restart though...).

10-01-2015, 02:48 PM
all quests have been followed accordingly, all field cleaned up. seems restart is the only viable solution atm =(

10-01-2015, 08:14 PM
Same problem,hat's how it should be.

so I got it


10-01-2015, 10:34 PM
Same problem and restart of the map does not work (the appointment of the Governor).
Probably a few weeks I do not feel like playing than resolve all bugs.

10-01-2015, 11:09 PM
From my end this is how it went down:
1st round on the map, didn't follow proper quest order, ended-up with, completely ignored the quest with my hero girl (i tried to lvl her up a bunch before sending her home, thought it would be a good idea to have her packing heat :D ) . Then, underground, liliat army nowhere to be fund.
Restared map.

Followed`up quest line completely to the letter (and by that i mean, in the order i received the quests, it's very easy to loose track of quests when they are given, you have to pay more attention), and everything ended up smooth, no bugs.

Most important order:
- assign her governor (take her to the castle, then drag and drop her avatar to the top left corner screen
- then u received quest to empty her army (make sure you have at least 1 solider of sorts in your inventory at all times during the campaign)
- unload army to tomas, and voila, then you can advance through the gates at spear pass and continue mission bug-free