View Full Version : Problem with Freedom Cry

09-18-2015, 01:43 PM
I have problem to download the Assassin's Creed Freedom Cry
I buy the game from ubishop at 23 June 2015 i download it and i never can play it because the game crashed every two minutes
now i change pc I tried to download it and i take this error (only to Freedom Cry, i tried to download another game and i can download)

Failed to start download
uplay is unable to start download.check that you have an active internet connection and sufficient space on your hard drive then try again

I have and internet and space

09-18-2015, 03:51 PM
i go to a friend and i copy the game and paste to my pc at first i have error i uninstal it and i do it again for 2-3 times finally the game play, now i have one error but who cares
i cant verify files i take this error (failed to validate games files. try re-installing the game and if the problem persists, contact ubisoft support)
and the game dont look for update

if somebody have a solution to tell me, if not never mind, now i can play it