View Full Version : [PC] I recently bought some Tom Clancy games but they don't work.

09-05-2015, 12:36 AM
I got some games in the Humble Tom Clancy Bundle. I downloaded and attempted to play Rainbow Six 3 Gold (it was the first one I downloaded) but it crashed and did not work after attempting to play the training. These are the two errors I had received:

First this one:

OS: Windows 7
CPU: AuthenticAMD Unknown processor @ 3394 MHz with 1023MB RAM
Video: AMD Radeon HD 7700 Series (1395)

General protection fault!

History: ResetDevice <- UD3DRenderDevice::SetRes <- UGameEngine:: Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

And then this one:

Trying to download version file from http://rspatches.ube.com/versions.cab to C:\Users\Dan\AppData\Local\Temp\ubi6E7D.tmp.
Failed to download this version file (Couldn't resolve host 'rspatches.ube.com').
Failed to download a version file. Update service cannot continue.

Oh and by the way, I have tried to launch them in compatibility mode for Windows XP SP3 and also tried launching as the administrator but it still does not work.
I am not very good with technical stuff so any help with this issue will help a lot!

09-05-2015, 11:23 PM
I have the same problem with Rainbow Six (thr fist one with no last name).
i can't make it work.

OS: Windows 8.1
CPU: Intel i5 650 @3.2 Ghz
RAM: 4 GB DDR3 1333
Video: AMD radeon HD 6770