View Full Version : AC3 online sync problem with other games

08-20-2015, 04:14 PM
I am having a problem with AC3 that it doesnt recognize as its on my account for the other games and on initiates site.

I have the following games on my account:
-AC 3
-AC Liberation HD
-AC Black Flag
-AC Rogue

When I started playing BF SP, I didnt get any legacy outfit (I should have got 1, for AC3). Also on MP I didnt get the relic for playing AC3 for example. On Player Profile also its not showing my level from AC3 MP, that is around 29 at the moment.

When I started playing Rogue I got 2 legacy outfits (1 for BF and other for Liberation, should have been 3 counting with AC3).

Also on the initiates site I got 2000XP for completing AC3 on the event feed but its not showing that I own it on the Collection section and on the XP Breakdown part ėts shows the default "No Game Data" as its think i dont own the game. The other games are showing correctly.

I have already opened a ticket for support, so far they told me to do the following:
-Run Uplay as ADMIN (my gaming computer is already with a ADMIN user per default, but tried that).
-Forwarded some ports on the router for the AC series and Uplay (did that but my gaming computer IP is already set as DMZ, tried setting the ports manually also same thing).
-Connected my computer direct to the internet modem w/o the router.
-Change the DNS for the Google one (I was already using Googles as default).

Besides that I also tried:
- Started a new SP game file to see if it works.
- Played some MP sessions to check if it update (my NAT classification is showing as OPEN)
- Tried Uplay and AC3 on my notebook with another internet provider, the achievements were successfully synched on it, even my savegame file was transferred w/o problem.

Also I dont have any firewall/antivirus installed and windows firewall is off on my gaming computer, speccialy to prevent situations like that.

Id like to know if anyone here have any suggestion or had a similar problem and what was done to fix that situation so I can tell support to work on that direction, as to so far they are only checking my internet connection, and that is clearly not the problem here.


08-22-2015, 08:38 PM
Hello and welcome JATFANT,

Sometimes if the game is not recognizing that you own and have previously played, what you need to do is play while connected to the internet. I would also try accessing Uplay in-game for each one just to be sure. This should make it possible for you to get the outfilts.

Also it can take up to 24 hours for everything to sync so you might not see it right away.

It's been a couple of days so I'm curious as to if it showing up for you or not. Please let us know. ;)


08-22-2015, 11:27 PM
Initiates is down isn't it?

So that it can relaunch with Syndicate?

08-27-2015, 06:38 AM
Hi Black_Widow9,

Thanks for checking this topic.

And yes the problem still happening.
I have played all the games connected to the internet and tried again several times, but AC3 didnt show any sign of life.
On that time I also got all the remaining games that was left for me from the AC series ( AC, AC2, ACB ,ACR and AC U)
I didnt register all of then yet.

And that is the interesting part, today I registered AC2 on uplay, in a few hours I checked the other games:
- AC BF when I started appeared the message that I have unlocked 1 legacy outfit ( so now I got 1 outfit for adding the AC2, but it should be 2 counting with AC3). On the BF MP didnt unlock the relic for playing AC3 MP yet.
- AC Rogue I got one more [got 3 now counting with the unlocks from BF, Liberation and AC2 (it should be 4 outfits counting with AC3)] + I got also the outfit and weapon from Arno for adding also AC Unity (that was almost instantly as I added the game to Uplay).
- Few hours after that, it updated the Initiate site and AC2 is showing as a game that I own and the status for the game. (AC3 still not showing that I own the, only got the 2000XP for completing the game and the profile unlocks related to that)

I have added now ACB and waiting to see if it unlock the last outfit on Rogue and one more outfit for BF.

Hopefully with those games I can get the outfits that are left for me, BUT the problem that it dont recognize my MP profile from other games and the initiate site there is nothing else I can do from my side.

So basically the bug that happened is that it was able to read my savegame, unlock the actions/rewards/achievements normally for AC3 but cant check that i own the game, that is weird.

Here are some pics:

AC Initiates Event Feed:
https://photos-2.dropbox.com/t/2/AAD5ISsZLWKQerHaaPq79RbmkfDvj176zN9cPfaJahLOgQ/12/277260058/png/32x32/1/_/1/2/ac.png/EPbf8IgCGOgBIAIoAg/Z3kfGlsA5aGlplG1mSm8XjRJcZGseyNNnLElJHSO9q8?size=1 600x1200&size_mode=2

AC Initiates Collection:

AC3 MP profile:
https://photos-4.dropbox.com/t/2/AAD8DqPE5C02o9o7q5Vnu4RCD83s1o5yDOs2oH1Orl418w/12/277260058/jpeg/32x32/1/_/1/2/ac5.jpg/EPbf8IgCGOgBIAIoAg/SsMUnAEDYzJ0nGzg1oCeC5ubS1JvbsW2rJh54QxbJwE?size=1 600x1200&size_mode=2

AC BF MP Profile:

Initiates is down isn't it?

So that it can relaunch with Syndicate?

Beside that bizarre bug i have, its working normally.