View Full Version : AC Brotherhood refuses to launch (Uplay)

05-15-2015, 01:00 PM
Assassins creed refuses to launch, it just starts the update, and then closes without an error. Razor Game Booster says " Razor is boosting your game" then suddenly says "returning to normal mode", i then decided to check the version by right clicking ACBsp.exe and properties but it doesnt have the version number (should be 1.03)

it could be a corrupted exe, but it was working before and after the update, its so F***ing annoying. i cant get it to launch
i tried adding the savefile manually to the "saved games" folder, but nope.

so if u cant give me a exe for the game to have a look if it was that would be great, if u cant plz help me

Also Uplay deleted my AC3 game save and now i need to start all over again.
and i cant get a save to start where i was upto (sequence 8)

05-15-2015, 02:06 PM
Did you make any recent hardware or software changes? As the first troubleshooting measure, I would disable Razer Game Booster (also, any overclocking you may have done). ACBSP.exe details tab doesn't show version number for me either, so I guess that that's normal.

05-15-2015, 02:54 PM
i unistalled Brotherhood just then and re installed it, it still wont run. i quit Razor Game Booster, and still nothing. no error what so ever, i had it working fully be for but its not working now

is there meant to be a play singleplayer/play multiplayer button like AC3

05-15-2015, 03:11 PM
No, just one button. The game is supposed to launch into single player, and then you can switch to multiplayer from there (not that there are any multiplayer games to be found, sadly, AC: B has such pretty maps).

05-15-2015, 03:22 PM

still cant launch it though

05-15-2015, 04:11 PM
Took this from a Steam forums user:

Try creating the following folder if you dont have it.

C:\Users\<USERNAME>\Saved Games\Assassin's Creed Brotherhood\Saved

I was having the same problem but this fixed it for me.

05-15-2015, 04:34 PM
still nothing i dont know whats going on, all my other AC games work

this is what i got from the Event Viewer after loading the exe


Log Name: Application
Source: Windows Error Reporting
Date: 16/05/2015 12:29:50 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: AaronBush
Fault bucket 1946018428, type 5
Event Name: BEX
Response: Not available
Cab Id: 0

Problem signature:
P1: ACBSP.exe
P3: 4dadd0f3
P4: ACBSP.exe
P6: 4dadd0f3
P7: 01924793
P8: c0000417
P9: 00000000

Attached files:
C:\Users\aaron\AppData\Local\Temp\WERBDD2.tmp.WERI nternalMetadata.xml

These files may be available here:
C:\Users\aaron\AppData\Local\Microsoft\Windows\WER \ReportArchive\AppCrash_ACBSP.exe_9d3d9570a77870cb bbffea5ee28afa902528b157_fb0860c8_1389d2b2

Analysis symbol:
Rechecking for solution: 0
Report Id: 97dd97d1-fb1f-11e4-82ed-00190e16d343
Report Status: 0
Hashed bucket: e48080fb08ad95a8e690f14add7a23f8
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<Provider Name="Windows Error Reporting" />
<EventID Qualifiers="0">1001</EventID>
<TimeCreated SystemTime="2015-05-15T16:29:50.000000000Z" />
<Security />
<Data>Not available</Data>
C:\Users\aaron\AppData\Local\Temp\WERBDD2.tmp.WERI nternalMetadata.xml</Data>
<Data>C:\Users\aaron\AppData\Local\Microsoft\Windows\WER \ReportArchive\AppCrash_ACBSP.exe_9d3d9570a77870cb bbffea5ee28afa902528b157_fb0860c8_1389d2b2</Data>