PDA

View Full Version : Help with Saitek Cyborg 3D GoLD USB J/Stick



sdcruz
02-14-2004, 11:00 PM
Hi,

I am having a problem with this stick and windows XP. Everytime I start my PC, I have to physically reconnect the Saitek Cyborg 3D GoLD USB J/Stick into the USB Port, XP does not detect that I have the stick already connected into the USB port. Does anyone know how to fix this problem, if you do please reply.



Thanks alot,

Shelton.

sdcruz
02-14-2004, 11:00 PM
Hi,

I am having a problem with this stick and windows XP. Everytime I start my PC, I have to physically reconnect the Saitek Cyborg 3D GoLD USB J/Stick into the USB Port, XP does not detect that I have the stick already connected into the USB port. Does anyone know how to fix this problem, if you do please reply.



Thanks alot,

Shelton.

Tully__
02-14-2004, 11:22 PM
I'd suggest posting this question at Saitek's forums, but a few things for you to check:

1. Have you downloaded Saitek's latest drivers? If the stick has been sitting on a warehouse shelf for a while, the drivers that came with it wont work so well in XP.

2. It may be the USB hub on your PC rather than the stick causing the problems. Try it without the drivers installed, if it still does that it's probably the USB hub.

3. Did you follow exactly Saitek's installation instructions.

=================================================

http://members.optusnet.com.au/tully_78th/Corsair.jpg (http://www.mudmovers.com/sturmovik_101/FAQ.htm)

IL2 Forums Moderator
Forum Terms of Use (http://www.ubi.com/US/Info/TermsOfUse.htm)


Salut
Tully

Extreme_One
02-15-2004, 02:43 AM
I own the same stick and used to have this problem with Windows98 but not with XP.

I could only re-iterate what Tully has suggested...

Good luck!

S! Simon
'''''''''''''''''''''''''''''''''''''''''''''''''' '''''''''''''''''''''''''''''''''''''''''''''''''' '''''''''''''''''''''''''''''''''''''''''''''''''' '''''''''''''''''''''''''''''''''''''''''''''''''' '''''''''''''''''''''''''''''''''''''''''''''''''' '''''
Download the RAF campaign folder here (http://www.netwings.org/library/Forgotten_Battles/Missions/index-9.html).

Download the USAAF campaign folder here (http://www.netwings.org/library/Forgotten_Battles/Missions/index-9.html). *NEW* Updated for FB 1.21

http://extremeone.4t.com/images/raf_sig.jpg

p1ngu666
02-15-2004, 08:58 AM
i got same stick, no drivers, works fine

http://www.pingu666.modded.me.uk/mysig3.jpg

Lixma
02-15-2004, 10:12 AM
Here you go. I have the same problem with mine. Apparently Saitek say it's a Win XP issue blah...blah...blah...

Just follow this little routine...

Right-click My Computer
Choose Properties
Change to the Hardware tab
Click "Device Manager"
Expand "USB Controllers"
Open "USB Root Hub"
Change to the Power Management tab
Uncheck "Allow computer to turn off this device"
Click "OK" until you get back to the desktop
Restart WinXP

sdcruz
02-15-2004, 08:01 PM
Thanks Sir!

S!