PDA

View Full Version : Trigger delay?



FatBoyHK
05-15-2004, 01:05 PM
I found that the gun would not fire at the instant you press on the trigger on the joystick, instead there is a short delay of about 0.1 - 0.2 second.....yes it is not serious, but still noticable.

Also, if I "touch" the trigger, i.e. press on it very lightly and releasing it immediately, the gun may or may not fire, it is a 50-50 chances.

but strangely, there is no delay or random fire problem whatsoever when I test with my keyboard....

I know what you may be thinking, but no, my stick is working very well, I verified it in the Control panel.

FatBoyHK
05-15-2004, 01:05 PM
I found that the gun would not fire at the instant you press on the trigger on the joystick, instead there is a short delay of about 0.1 - 0.2 second.....yes it is not serious, but still noticable.

Also, if I "touch" the trigger, i.e. press on it very lightly and releasing it immediately, the gun may or may not fire, it is a 50-50 chances.

but strangely, there is no delay or random fire problem whatsoever when I test with my keyboard....

I know what you may be thinking, but no, my stick is working very well, I verified it in the Control panel.

Curly_109
05-15-2004, 03:20 PM
Really you're right. I've noticed it and it's pretty funny. Or annoying, whatever. I've aiming with Mk108 at a high angle climbing LA7 and squeeze trigger for a moment and nothing happens. It's not really my fault or stick's http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

Covino
05-15-2004, 06:47 PM
This problem was introduced in an old patch for the original IL-2 and hasn't been fixed (or noticed) yet. My old Microsoft Sidewinder had the same problem. The trigger firing was a bit delayed sometimes when firing even though everything tested fine in the control panel. It made aiming big cannons especially hard because it fired a split second too late or didn't fire at all.

The joystick had no problems in any other games and I tried everything to get it to work to no avail. I've since switched to the MS Precision Pro 2 (a USB joystick, maybe non-USB joysticks have this problem :/) and no more quirky firing.

Slammin_
05-15-2004, 10:37 PM
I noticed this as soon as I went to USB. Plug a joystick into the game port and the delay goes away.

Timex62
05-15-2004, 11:14 PM
Really? My X45 still has that fraction of delay. Very irritating with the cannon.

Close to the Edge

FatBoyHK
05-15-2004, 11:35 PM
So what should we do? report to Ubisoft? The longer it happens, the more annoying it is http://ubbxforums.ubi.com/infopop/emoticons/icon_frown.gif

BuzZz_WG
05-16-2004, 03:57 AM
I remember Lock-On had the same problem. A work-around was to map the space key to the trigger. Something like using the keyboard with the joystick. I notice the delays as well, but haven't tried to map my joystick to the fire key on the keyboard.

Btw. I have a MSFFB2, so USB. Don't know about other joysticks.

BREAK! BREAK!
Nevermind...