View Full Version : [SOLVED] ACIII Deluxe Edition - Not being able to play DLC

03-15-2015, 12:56 PM

I wanted to make this thread just in case other people had the same annoying issues I had with properly activating my copy of ACIII's Deluxe Edition. That is to say: the base game and the DLC that should come with it. The issue for me was that I purchased the game, entered my key in the uPlay client. The game was activated, but upon starting the game no DLC was unlocked. After putting the key in again inside the game, I unlocked at least a billion things, but I could not access "The Tyranny of King Washington", for example. When returning to the client, uPlay kept claiming I did not unlock any content at all, except the base game. The service claimed I did not deserve access to it's additional content even though I bought the version of the game with all the DLC. When looking for help, ever helpful the internet always is, you may find that some people will proclaim you need two keys, some will say you obviously got the game from a dubious seller and therefore you must be purged. All of these and others are not true.

I did not receive help from others, so I had to solve the problem myself in hours of meticulously searching for clues. Here's a step-by-step guide, from the beginning.

You need: One (1) legit CD-Key of Assassin's Creed III Deluxe Edition written on a piece of paper. A legit uPlay client must be installed and you have to be connected to the internet.

1. While in the uPlay client, activate your purchased product.

2. Download the installer for the game.

3. Once downloaded, choose to "Install" the game. For Steam users: this kind of stuff is normal. I know you guys are used to the convenience of playing the games you bought when it's downloaded but when you use uPlay you have to lower your standards in order to get over this annoyance.

4. When ACIII is installed, choose the option to play the game. Normally you should be downloading the first patch. This is because in uPlay you're always downloading the game's oldest version. When downloaded, you'll be taken to another installer where you can install the patch.
4b. After the patch, you should be inside the game. However, you have to exit the game and restart it again to download and install the second patch. Do this over and over until you feel like you're dying of old age.

5. After you have installed all patches, re-enter the game and choose the 'Extra's' option in the main menu. Here you'll find the option to redeem a code. Here you must reuse the CD-key you used to unlock the game in the uPlay client earlier.

6. After receiving tonnes of messages telling you how much stuff you unlocked, exit the game again. If you are unlucky, uPlay will claim you do not deserve access to the additional content like "The Tyranny".
6b. If you're not sure if you unlocked the content you bought, enter the game again. In the main menu there is an option to play the "The Tyranny" DLC directly. If you see options like: "Start New Game" you're in the clear. If you get an error message you just got screwed by uPlay. But here's the solution.

7. You can perfectly play the DLC, but the only thing holding you back is the fact that uPlay doesn't believe you unlocked the DLC. You must search the internet for the installers to the:

-Hidden Secrets Pack
-The three episodes of "The Tyranny" DLC
-The Benedict Arnold DLC (I have not found this DLC as of yet, but I read that it's not a very significant piece of DLC)
-The Battle Hardened Pack (same)

These packages can only work with a licensed product, so these installers won't help pirates. I've always deemed the first two as the most significant, and luckily they are the only ones I've found. They aren't difficult to find, it's just that the process of figuring all this stuff out was difficult. When I downloaded the .rar files to the installers, and installed the DLCs seperately, everything worked perfectly.

I hope this was informative for the people who are in need of a solution to this kind of problem. I kind of felt it was my duty to share this solution with other people. If I could help at least one other unlucky person, this will have been worth it.