PDA

View Full Version : Game soft-locks connecting to leaderboards or TC, general connection issues



Waistless
02-01-2015, 11:17 AM
Hi, I've been having issues lately where despite loading the game and signing in just fine, half the time the game will refuse to load the leaderboards or track central. And upon loading a search in TC or selecting a certain category in a track leaderboard like teams or my score, the game will become unresponsive to any input (it will play sound for trying to move about but do nothing) and I have to restart the game to navigate menus again. Again, the game signs in fine, uplay works fine, but leaderboards and TC do not when this is happening.

I've been monitoring what happens during this in TCPView. Normally trials fusion will make a handful of TCP connections to api-ubiservices.ubi.com, one TCP to lb-web-tmg-ncsa.ubisoft.com (both HTTPs port) and two UDP connections (tcpview doesn't say where they're connected to or what port). What will happen is when I say move selection from one track to another, as it tries to find friend scores in the preview, all I will see happening is a few packets sent and recieved on one of the UDP connections, but will never load any scores. No data being sent either way on the api https connections at all.

Same deal when stuck on track central. A few packets sent and received on the UDP connection, otherwise nothing.

Some traceroutes to look at:

Tracing route to api-ubiservices.ubi.com [216.98.48.206]
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms 192.168.1.1
2 27 ms 33 ms 28 ms 172.18.213.9
3 41 ms 28 ms 29 ms 172.18.70.129
4 30 ms 27 ms 28 ms bundle-ether4.woo-edge901.brisbane.telstra.net [203.50.44.36]
5 32 ms 29 ms 31 ms bundle-ether5.woo-core1.brisbane.telstra.net [203.50.11.136]
6 47 ms 44 ms 44 ms bundle-ether11.chw-core10.sydney.telstra.net [203.50.11.70]
7 43 ms 44 ms 42 ms Bundle-ether17.oxf-gw2.sydney.telstra.net [203.50.13.70]
8 45 ms 47 ms 47 ms bundle-ether1.sydo-core01.sydney.reach.com [203.50.13.38]
9 44 ms 43 ms 48 ms i-0-2-0-6.sydo-core02.bi.telstraglobal.net [202.84.223.46]
10 180 ms 179 ms 187 ms i-0-2-0-7.1wlt-core01.bx.telstraglobal.net [202.84.143.149]
11 218 ms 219 ms 221 ms i-0-5-0-5.eqla01.bi.telstraglobal.net [202.84.253.30]
12 269 ms 266 ms 271 ms ix-4-2-0-0.tcore1.EQL-Los-Angeles.as6453.net [206.82.129.57]
13 364 ms * 366 ms if-6-20.tcore2.LVW-Los-Angeles.as6453.net [64.86.252.65]
14 357 ms 357 ms 363 ms if-22-3.tcore2.PDI-Palo-Alto.as6453.net [64.86.252.38]
15 355 ms 356 ms 359 ms if-11-3.tcore2.CT8-Chicago.as6453.net [66.198.144.58]
16 359 ms 357 ms 360 ms if-3-2.tcore1.W6C-Montreal.as6453.net [66.198.96.45]
17 * 66.198.96.18 reports: Destination net unreachable.

Trace complete.
Tracing route to lb-web-tmg-ncsa.ubisoft.com [216.98.48.11]
over a maximum of 30 hops:

1 4 ms 4 ms 3 ms 192.168.1.1
2 31 ms 27 ms 27 ms 172.18.213.9
3 28 ms 26 ms 30 ms 172.18.70.133
4 27 ms 31 ms 31 ms bundle-ether4.woo-edge901.brisbane.telstra.net [203.50.44.36]
5 28 ms 31 ms 27 ms bundle-ether5.woo-core1.brisbane.telstra.net [203.50.11.136]
6 51 ms 45 ms 42 ms bundle-ether11.chw-core10.sydney.telstra.net [203.50.11.70]
7 44 ms 46 ms 45 ms Bundle-ether17.oxf-gw2.sydney.telstra.net [203.50.13.70]
8 43 ms 42 ms 44 ms bundle-ether1.sydo-core01.sydney.reach.com [203.50.13.38]
9 44 ms 51 ms 47 ms i-0-2-0-5.sydo-core02.bi.telstraglobal.net [202.84.223.42]
10 188 ms 183 ms 191 ms i-0-2-0-7.1wlt-core01.bx.telstraglobal.net [202.84.143.149]
11 218 ms 219 ms 219 ms i-0-5-0-5.eqla01.bi.telstraglobal.net [202.84.253.30]
12 271 ms 267 ms 274 ms ix-4-2-0-0.tcore1.EQL-Los-Angeles.as6453.net [206.82.129.57]
13 362 ms 369 ms 361 ms if-6-20.tcore2.LVW-Los-Angeles.as6453.net [64.86.252.65]
14 361 ms 360 ms 359 ms if-22-2.tcore2.PDI-Palo-Alto.as6453.net [66.198.144.73]
15 345 ms 350 ms 345 ms if-11-3.tcore2.CT8-Chicago.as6453.net [66.198.144.58]
16 349 ms 353 ms 346 ms if-3-2.tcore1.W6C-Montreal.as6453.net [66.198.96.45]
17 * 66.198.96.18 reports: Destination net unreachable.

Trace complete.

Maybe its because I'm living in Australia trying to connect to servers in Canada, I don't know, but I would like my game to be more responsive if this is always going to be a problem.