PDA

View Full Version : SLI is completely broken in ACU and Ubisoft doesn't care



CruisD64
01-27-2015, 03:35 AM
Ok. This is mostly a rant and probably the millionth time everyones heard it (I don't care). It's very frustrating that a patch which was released over a month ago ruined SLI and is not fixed yet. ACU has been unplayable and for a game so mainstream, it's shocking. How the hell does a patch get released that breaks SLI. Did you even test it? Monkey's pushing buttons, maybe? At this point I feel like I should be compensated because Ubisoft obviously doesn't give a crap about ACU PC version (and many other games FTM). This WILL be the last Ubisoft game I ever buy. Get it together, people...smh

strigoi1958
01-27-2015, 03:56 AM
Nvidia doesn't care about sli... they want your money but the geforce forum is full of complaints and the lack of support or designated drivers for sli or triple or quad sli... some people are buying quad titan z's.... that's 20,000 worth of cards... and they get given the same driver that has to run a gt250 or something equally as restrictive....

shame nvidia doesn't treat it's best customers better :(

CruisD64
01-27-2015, 07:45 AM
Yeah, I agree, however I think in this case its Ubisoft that **** the bed. It's up to the gaming companies to properly support things like SLI and PhysX. There are API's created just for that purpose. The sad thing about this is that these updates are mandatory and in Ubisofts case cripples more than helps. ACU worked fine with SLI prior to the December patch and it's been a MONTH since that patch was released. It appears their QA team is non-existent and lack thoroughness. Ubisoft, please allocate some resources so that these graphics settings that you claim to support are actually supported. Unfortunately I have a feeling it's going to be nVidia that ultimately fixes this problem, because I honestly don't see Ubisoft stepping and doing anything about it.

PS - I joined this forum just so I could start this thread.