PDA

View Full Version : Assassin's Creed: Unity DLC Glitch



rielmendoza
01-23-2015, 01:32 AM
Guys why dos this happen when iI lunch the dlc (look at link)
https://www.youtube.com/watch?v=-QVzgUHDZgY

I lunched the dlc crashed and this happened

strigoi1958
01-23-2015, 01:40 AM
what is your pc system ?
have you verified the game files ?
do you have anything running in the background ?
do you have the latest graphics drivers ?

rielmendoza
01-23-2015, 10:53 AM
Processor: Intel i3 3.2 ghz
Gpu: Nvidia geforce gt 610 2gb
Ram: 4gb
Os: windows 8.1


I know i dont reach the minimum requuirements for the game but i checked this video
: https://www.youtube.com/watch?v=IqZwiJoJ6lU

MY gameplay : https://www.youtube.com/watch?v=4FHEzVKQyDo

How do i Check the graphics driver

things running in background
-U torrent
-Google Chrome
-Fraps

strigoi1958
01-23-2015, 11:17 AM
I am afraid you graphics card is a long long long way below the requirements, I see you have the resolution very very low... something like 720 x 576 I think it is possible that running the game AND the dlc may be too much even at that low resolution... I think there is only one more resolution lower than you are using now 720 x 480 you may need to go down to that but...

FRAPS uses a lot of resources so turn that off... it will kill the game and turn off everything you can

To be perfectly honest I am surprised it runs at all on your system and I am not sure I could play it like that but I'm glad it works for you and you are at least playing.

If that fails then you will have to forget about dead kings until you upgrade sorry....

to check your driver go to the start button and in the box type dxdiag... it will show up and just run it.... on the tabs at the top, click the second one..... Display..... on the right it will say driver and the second line is version..... the last 5 numbers are the version.... so if it says 9.18.13.4725 then the driver is the last 5 numbers... 347.25 ................9.18.13.4725

updating your driver from the nvidia driver page may help... it may give a couple of FPS

sorry I cannot help you more

rielmendoza
01-23-2015, 12:34 PM
Thanks for the advice I have updated it and turned off fraps and the game feels much more smoother than last time but dead kings still does not work so I'll give up on that and focus on making videos for my channel
https://www.youtube.com/channel/UCKcGHqG39xd--TnlknZNxmQ