View Full Version : ACOD - PC

Pages : 1 2 3 [4] 5 6 7 8 9 10 11

  1. Game crashes when in Attika region or nearby Athen capital
  2. 16:9 1920x1080 Black Screen Problem
  3. "How the mighty have fallen" challenge not unlocked
  4. [BUG] White Sailing "Loot" Marker is Stuck on my Screen
  5. Lola lieutenant buggued
  6. Perikles's Symposium - no Herodotos
  7. Torches Tanking FPS
  8. abandoned by the gods, litteraly
  9. Holy CPU Bound Batman !!!!!
  10. @DEVS --- intel i7 8700k pegged at 90% cpu usage
  11. Bug quest and club reward
  12. Daughters of Artemis suddenly became hostile
  13. Free chapter 1 Helix still not received, support not helping
  14. I bought ODYSSEY GOLD and receive ORIGINS
  15. Diolkos West ainigmata
  16. Grass setting
  17. Support Questions
  18. Why Is Uplay So ****ing Garbage??? (AC:Odyssey CONSTANTLY Crashes)
  19. Bayek and Evie appeared.
  20. Live event quest (black wind) vanished from my quest list
  21. Epic Armor texture white?
  22. Ingame F1 key check performance CPU usage 0%
  23. still carshing
  24. I cant get stable 60 fps even in low settings
  25. Bug: Statistics on abilities acquired 1% and challenges 50 orichalcum
  26. Missions not working
  27. after all long time with Ubisoft, this will be that last game.
  28. The game has micro-stuttering in cutscenes after patch 1.05.
  29. Unsynchronized entries in Uplay Statistics table
  30. Nível máximo, 50
  31. FPS Drop During Night
  32. mercenary bug...
  33. Nvidia Control Panel Doesn't work most of the time
  34. game freezes early
  35. Can't start game
  36. Accessibility problem in sea battles
  37. When do we get the detailed stats page?
  38. Navigation markers almost invisible in daytime
  39. [BUG] Podarkes the Cruel Issues!!! Many Issues! ( Beware for Spoilers )
  40. [PC] Game crashes between Cutscenes A Family’s Legacy [Spoiler]
  41. Progression bug after completing "Unearthing the Truth"
  42. Rarely visible loading low resolution textures and microstuttering on cutscenes
  43. Stuck under a house in Hydrea
  44. Machaon the Feared Bugged
  45. Black Wind Epic Ship Bounty Quest Disappeared
  46. crashing when quitting the game
  47. Permanent Freeze while Autosave on the sea
  48. Imperial Edition, but no boosters included?
  49. Cant start AC Odysee
  50. Evie not showing on ship
  51. Quest Bug: Gutter Runner
  52. Problems with D-Pad left and right in V 1.0.5
  53. Throwing javelin breaks the sea battle
  54. Constantly freezing/exiting the game
  55. Issue with Barnabas Questline in Lemnos
  56. BUG - After "The last hope of Athens" Phebe - SPOILER!!!
  57. 4 bugs discovered so far
  58. game crashs near the fasttravel points on skyros
  59. Game slows to a crawl after 1.0.5 patch
  60. "Barnabas Abroad" quest bug
  61. Deleted saves
  62. Problems with Ship Lieutenants
  63. Problem with blocking FPS in game
  64. Mercenary system broken
  65. Black Wind Epic Quest Disappeared
  66. Adrestia docking bug at Kos
  67. Cursor/game issues
  68. Maximum level, 50
  69. Left To Dye
  70. Attacking conquest only gives 1 piece of armour
  71. HDR on PC doesn't look good!
  72. The game crashes after the first cutscene
  73. Fighting Medusa for Ligea Quest and game crashing consistently
  74. Quest Bug - Clothes make the daughter
  75. Orichalcum Fragment on Fort of Arkas on Arkadia
  76. Lip sync animation errors in cutscenes
  77. I bought the season pass and game on steam and need activation key in uplay
  78. New 'Underworld Armor' is very Pixelated
  79. I am haveing a problem with Assassin's Creed not showing up in game library
  80. [BUG] - The % Damage with Heavy Blades Engraving doesn't unlock!!!
  81. Level 50+ Mercenaries Missing Ship Perks
  82. Bounty System NOT Working!
  83. Continues to crash/freeze
  84. Graphic bug and freeze/crash
  85. missing lieutenant bayek
  86. Defending Islands issue
  87. Missing piece of Pirate Set (Gods of the Aegean)
  88. Killing cultist member
  89. Shop not working?
  90. 200 Helix credits for buying Gold Edition/Season Pass owner.
  91. Playing AC: Odyssey disable my HDD ( The disk on which AC is installed)
  92. What are best drivers for nvidia now?
  93. Missing content?
  94. Underworld pack removed from inventory
  95. [Bug] stupid AI
  96. AC Odyssey Throw The Dice quest
  97. Weird fps drop since update!! Can anyone help?
  98. Update 1.06. Crashes continue
  99. Kills don't count towards the unlocking of the engravings
  100. There was a problem while trying to communicate with an ubisoft online service
  101. Undiscovered Mercenaries after discovering, bug?
  102. The game is not running in full screen mode.
  103. Limited language options
  104. Change of female and male voice.
  105. Ship menu screen new lieutenant notification issue
  106. Unable to leave Attika
  107. Blue Yeti + AC Odyssey will not activate
  108. Post Update Bug- No More Quests
  109. "Public Opinion" main quest bug
  110. mercenary rank 1 locked?
  111. Update 1.0.6 reversed the stability of 1.0.5
  112. Massive FPS drop issue since patch 1.0.6.
  113. v 1.06 Can't use bow
  114. Various Model/Animation Issues (still present in 1.0.6)
  115. Tekton still not dismissing after patch 1.0.6
  116. My own lieutenants are hostile to me, and a couple other things
  117. Alexios - Now has a woman's voice
  118. Bayek as crew member
  119. Bad really bad perfomance.
  120. Game Breaking Bug at the Symposium
  121. Persian Remnants Treasure Chest Bug
  122. No new quest available - Setting the Stage - The Show Must Go On
  123. 1.06 Patch for Project Stream?
  124. Odyssey Freezing and locking up PC after 15-45 minutes
  125. Ubi Keeps closing unresoled tickets. Is this normal?
  126. 5.1 Sound Systems are not working?
  127. Explosive arrows set me on fire!
  128. All important NPCs are dead
  129. new game plus
  130. Second melee wheel
  131. Can't end mission, we're treasure hunters Pirate Islands
  132. Game has stopped saving photos in the default folder
  133. Purchased Maps not showing on map screen
  134. WTB - Lykaon remains stuck on a prop during Sins of the Past
  135. Bugs in "Ashes to Ashes" abnd¨
  136. Purchased Map icons not showing on map screen
  137. [RESOLVED] Conquest Battle (Naval) for Obsidian Islands NOT triggered
  138. X1 controller for PC problem
  139. Cant get rid of bounty
  140. Gamebreaking Bug (spoiler)
  141. Can't complete the Olouros Fortress
  142. Bug "He Waits"
  143. Strange display issue on laptop.
  144. Project Stream - AC:O - Engravings missing from list (game breaking bug)
  145. can not PAY any bounty
  146. Perikles Symposium bug Patch 1.0.6
  147. Game crashed after 1.06 patch
  148. The Fall of Deianeira bug... can not advance in story
  149. AC Odyssey Bugs/Gripes - PC version
  150. [Bug Report] Delivering a Champion
  151. Issue with Nemean Lion Set Bonus
  152. Any Problem
  153. Can`t use any melee weapons
  154. What sort of nonsense aiming is this?
  155. Xbox 1 wireless controller
  156. PC Game crashes after 1.06 update
  157. probleme
  158. 1.0.6 patch is downloading entire game!
  159. Mercenary system not working now.
  160. Cannot get access to, weaken or kill the Sparta leader in Lakonia!!
  161. Missing Conquest Battleground for Petrified Islands
  162. Bug after completing Atlantis questline [SPOILERS]
  163. Can't return to Layla bug [Spoiler]
  164. Game Broken After 1.06 Patch — Constant Crashing to Desktop
  165. Barnabas is invisible on ship
  166. Did i just pay to be frustrated?... Feels like it!
  167. I want a refund
  168. RTX GPU or Game Glitch?
  169. incapable d'utiliser l'épée
  170. Four mythical beasts slayed. Only two counted
  171. Main story quest bug
  172. [BUG] - New Unlootable Orichalcum Ore Spot!
  173. Stuck ithe labyrinth
  174. last 2 classic challenges
  175. Monger bug - PC
  176. Consulting a Ghost STUCK!!!
  177. Ship bug
  178. freeze and stutters issues post latest update (11/5/2018)
  179. Quest: Writings on the wall bugged bear
  180. Another buggy orichalcum fragment
  181. Freeze / Textures Load
  182. Helix credits not credited
  183. Ubisoft Club Server Problems (Classic Club Challenges)?
  184. Daily orichalcum quest giver attacked me therefore failing the quest completion
  185. Cloud Backup Fail - days of progress lost
  186. Cannot complete Ruined Temple of Apollo
  187. 1.0.6 still not fix the Mercenary system?
  188. Xbox One controller trigger impact supported?
  189. Bug- The Tribute
  190. Online Service Error [0x00200101]
  191. Bug with Orichalcos Quests and the Tyrant
  192. A question for Rx 580 users
  193. RTX 2080Ti What FPS you getting?
  194. game crash
  195. game crashes when I'm on the boat
  196. Increase speed of walking for character
  197. "Bare It All" quest bug
  198. Missing Epic Armor Pieces after completing cultist lines
  199. Conquest Battles Resetting
  200. Question for the New Epic Ship (Tyrant)
  201. Bug starting Blood in the Water quest
  202. Different savegame and russian language after 1.06 update HEEEEELP
  203. R7 2700x + 1070ti - What FPS are u getting?
  204. blurry screen
  205. Movement
  206. Custom Camera Tool question
  207. Game crashes when wearing Pilgrim Set
  208. slot for second character
  209. Pushed under map
  210. Roxana bug in regards to quest progression
  211. Bug Quest Auto-Complete on Kythera with Diona
  212. DS4 Layout - PC version
  213. Selling Gear: Lvl 50 worth 10% of lvl 49 gear?
  214. Horse trotting speed should be increased.
  215. RTX 2070 compatible?
  216. Bug with The Silver Griffon
  217. Didn't get legendary loot from Sokos
  218. ubisoft online service error 0x00200101
  219. Broken quest - Clothes Make the Daughter.
  220. Fight options disappear during a fight
  221. plantage du jeu
  222. [RESOLVED] Game stuck on "checking for additional content" screen
  223. Bug on Side Quest Mission
  224. All quests disappeared, ALL
  225. Xenia's mission: Throw The Dice
  226. No mercenaries appear anymore when you have managed to hire 38 of them on your ship
  227. Animal companion kills
  228. Graphic setting
  229. Estate Envy Ainigmata Ostraka bug
  230. Weekly events not showing up
  231. Across the border (npc Bug)
  232. Insanely Slow FPS
  233. Keyboard Cougar 700k issue
  234. Rhexenor the Hand - Delian Cultist
  235. Hermes Homie Achievement Bug
  236. Child of Poseidon
  237. Odyssey patch 1.07
  238. bug or glitch
  239. ubisoft reward the blind king
  240. Odyssey crashes after 1 minute of entering the game
  241. Stentor bug
  242. My safe file got lost and corrupted can't get it to work - Need Help
  243. bug or glitch
  244. My code for Odyssey still hasn't been given to me by amdrewards
  245. Bug makes game crash when approaching Seriphos
  246. PC restarts after hitting continue...
  247. glitch or bug
  248. Ruins of makris
  249. Framerate spikes
  250. Can't find or kill Rhexenor the Hand - Delian Cultist - mission bug/problem