View Full Version : ACO - PC

Pages : 1 2 [3] 4 5 6 7 8

  1. [Discord] [Dutch] AC Origins
  2. X'box360 controller bugs
  3. Vicious bug in Aya's quest "Blade of Goddess"
  4. Daily quests ?
  5. "The Odyssey" Quest Bug.
  6. Make a shield toggle option
  7. got someone else his game save after patch
  8. Assassin's Creed Origins: Performance Configurations
  9. Issues Retrieving Isu Armor (Help)
  10. Master Hunter Bugged
  11. Unable to equip narcotic darts
  12. [PC] Save Location Photo mode!
  13. Environment Details causes since 1.03 Stutter / Freezes
  14. May help multi monitor
  15. Potential sound fix and slight performance gain.
  17. Strange lighting/shading effect in caves
  18. 40-60% CPU Usage on main menu???
  19. Horse Clipping bug during side quest 'In Protest'
  20. Numerous bugs and no achievement rewards for completed ones on PC
  21. Mouse sensivity when aiming with the predator bow is too high !
  22. Mouse cursor in Uplay overlay not displayed
  23. Can't change in-game Resolution...After...Update 1.03...!
  24. Loot bug THE TAX MASTER
  25. Stuck in Loading mode after Reloading Quest Objective
  26. Unable to start AC Origins
  27. Low FPS after patch
  28. Movement speed issue on PC
  29. Problem with bought helix credit
  30. Game crashes when I try to fight the first enemy.
  31. Lake Mareotis - trireme
  32. Still unable to switch to sleep darts
  33. Support PC gamepads
  34. [PC] "Murder in the Temple" bugged (side quest spoiler)
  35. Ambush at Sea Missing
  36. Initialization error 4
  37. [PC]Having occasional hangs with no correlation or reproducibility, sound still plays
  38. Hard FPS drops after i turn off and turn on the game
  39. Collection Of Issues I've Had
  40. Quick tool change does not work
  41. Why we can't sell outfit!!
  42. Why we can't sell outfit?
  43. Game reverted back to the beginning, kept my level 40/items
  44. Noise in sound after 1.03 patch
  45. language changed?
  46. Gambreaking - Protector outfit has no hidden blade. Please fix.
  47. UNPLAYABLE after patch!
  48. menus area under "controls"
  49. Supernatural Djinn Flaming warriors? Normal or bug?
  50. Uplay won't start!?
  51. Naval quest dissapear?
  52. PLS Anyone: unable to perform ultra combo skill
  53. Unable to Purchase Currency
  54. Stutter / temporary freezes in and around Sais
  55. Crash after selecting abilities tab every time.
  56. "Aya: Blade of the Goddess" Crash mid cutscene, save corrupt
  57. Sound game... 0/10
  58. Seems Like Ubi is shooting themselves in the foot
  59. Crashes when starting campagin
  60. Why some of the npc faces look like this?
  61. Bug report: snéfrou romboidal pyramid
  62. Game Breaking Glitch in Battle of the Nile quest.
  63. Can't Play Due to Audio Issues
  64. Cant play the game, Stuck in mission.
  65. Aya: no audio or subtitles
  66. Found a drowning giant in Lake Mareotis
  67. Keyboard input isn't registering, jams the last key pressed
  68. Outside environments 60fps, inside areas (tombs etc) 45fps with torch lit 4k 1080ti
  69. Mission Defend Caesar "Battle of Nile" bugged with 1 spear-unplayable,unprogressable
  70. No response from support
  71. Question For Players
  72. Club Challenges wont give points or show as complete
  73. [PC] Bug Report - Shield toggles even when set to hold. Plus, Senu trouble.
  74. Patch 1.3 added DSR support but where is SLI support?
  75. Why do my Gazelles keep trying to be human? [Visual Bug]
  76. Static/crackling audio
  77. Requirements are a scam
  78. How to unlock "No Limits" on Ubisoft Club Challenges?
  79. crash after game loads
  80. Game Breaking Problem!!!
  81. Broken animus in laylas cave wont let me go back into the game
  82. Failed Quest
  83. Game Update check
  84. Lighting bug in caves / pyramids
  85. Save game transfer to another account
  86. No HDR Support on PC!!!!!!
  87. Hard freeze anytime at the same place
  88. Phylakitai missing after being killed
  89. Terrible collision at sea sent one ship skyward
  90. Opens in windowed mode
  91. Stuck inside/underneath ship
  92. crash in Menus city main quest
  93. Stuck at 98% progression, can't get 100%
  94. ps4 1.0.4 Update (pc?????)
  95. I guess Ubisoft really doesn't care
  96. Where is multigpu (SLI/CROSS) support?
  97. Latest Patch Introduced Stutter In certail Memphis locals
  98. No HDR - PC Version ?
  99. [Quest Bug] "What's Yours Is Mine" - nothing missing from inventory (slight spoiler)
  100. Landscape Texture pop-in.
  101. About the voices/sound issue...
  102. Mouse Aiming sensitivity too high
  103. Passed through stairs
  104. Game does not want to start
  105. Is PC getting patch 1.04? When?
  106. All Russian Menus after the Patch
  107. I have the Dawn of The Creed Edition (150€ cost) and I haven't get the 500 Helix Coin
  108. Post here for support of adding HDR display output on PC
  109. Lots of clipping on Bayek
  110. New Online Photo Mode
  111. Precious Bonds Mission not completing
  112. If DRM not the issue can you help me why I am getting over 60% CPU usage in the Menu?
  113. CPUCores :: Maximize Your FPS (Is it effective?)
  114. Game won't start...
  115. Bug with Autosave and loading
  116. Logitech headset sound problem/missing (possible workaround)
  117. Aya using Bayek's face and body in Alexandria "Aya: Blade of the Goddess[...]"
  118. Peripherals having laggy to no response during gameplay movement but fine in loading
  119. problem my pc freezes and sometimes restart itself
  120. Low audio problem and no bass.
  121. Sound Issues (surround + central speaker for voices) during cutscenes
  122. Something's wrong? Cat with cigarette in menu
  123. Assassins Creed Origins [Discord server]
  124. Photo mode stuck on saving
  125. Roman Centurion pack inaccessible
  126. Cutscene Stutter
  127. Installation error 4
  128. Bug in side quest "His Secret Service"
  129. Cannot connect to the Ubisoft server to install the Centurion Pack.
  130. 2 Patches Later & Still No SLI Support...
  131. Trails of the Gods missin quest item
  132. crash at 'checking for additional content'
  133. Missing Trial
  134. Key activated but still no game shows in UPlay and no reply from support
  135. trial of the gods problem
  136. V-Sync increases GPU load by 25%-points compared to FPS-Limit
  137. Logitech Headset bug/no sound
  138. Ground texture disappears and is replaced by a reflective surface
  139. Activate the ancient mechanism ? for everyone
  140. Camera not working
  141. Application Error 0xc 0000005
  142. Trail Of The Gods
  143. Game keep crashing
  144. Restart Quest
  145. Please... Stop loading games from 3 days ago..
  146. PLS HELP: missing informant desk in Memphis?
  147. Trials of the Gods - No quest item and continual fight loop
  148. Things This Game Desperately Needs Patching
  149. Black screen when quitting to desktop.
  150. Weird glitch that makes Bayek stop running
  151. [pc] bsod
  152. Models/artifacts stretched to center of world
  153. Self Rotating Camera ???? WTF
  154. Problème : Erreur d'écriture disque - MàJ du 07/11
  155. Is ACO ok to play now
  156. Weird lighting in caves
  157. 7th of november patch error - won't install properly
  158. PC 11/7 1.04????? (where is it?)
  159. Can we get a fix for the bow "wings of Ashur" ?
  160. My Brother for a Horse - Quest text error
  161. problem with the game
  162. FPS drops after 1.0.3 patch everything was fine before
  163. Error 0x00200100
  164. Controller Input Delayed after 10 - 15 minutes of playtime
  165. Screenshots Folders ACO with the screens X2 for each one, what's about you ?
  166. Congratulations Ubisoft Support
  167. Uses only 1/3 of all health
  168. Melee attacking cobra's kicks to desktop
  169. Game runs like garbage since newest patch
  170. Arabic subtitle missing
  171. Battle of the Nile bug even after patch
  172. crash every 20 minutes
  173. Assassin's Creed Origins - Game Progression stuck at 99% / Other Issues
  174. Anubis Quest Bug
  175. Nvidia owners!!
  176. How to sell clothing?
  177. Still waiting for 500 helix points from Season Pass
  178. How to sell clothing?
  179. Photo-Mode Solution found
  180. Lighting glitch underground
  181. AC Origins
  182. Website photo mode problem
  183. Sound was workign last night now no audio at all.
  184. No stats on Steam version
  185. No reward after I killed anubis
  186. No Ansiotropic Filtering (AF) on PC?
  187. Overpower not working anymore.
  188. ACO Seasson pass??
  189. Escort Praxilla from the Shrine
  190. Why can't we hide these ability point and tool upgrade icons?
  192. Bug Reports
  193. I am stuck at loading screen in "the last of the madjay" quest
  194. Respawning at Viewpoints
  195. CPU usage 100%
  196. where is the download link for the patch
  197. Assassins creed origins crashes on startup on pc
  198. Denuvo DRM causes SSE4.1 AND 4.2 requirement
  199. Anyone can help me with my glitch!?!?!?!?!?
  200. I can't complete side quest after my system crashes.
  201. Missing Naval Missions (Minor Spoilers)
  202. outposts
  203. Assassin's Creed Origins: Uplay - Missed Rewards
  204. Strange Audio Bugs
  205. How to force 1440 resolution?
  206. Constant CTD at The Lizard´s Mask [Spoiler]
  207. [Bug] No lip sync during cutscene (Spoiler)
  208. Savannah Marauder outfit bug (skinning/weighting problem?)
  209. Running an unsupported graphics card driver
  210. Lions cougars falls thru map when killed
  211. Ridiculous amounts of crashes
  212. No way to get up to level 40 till nov.14 for me
  213. Underground lighting is messed up.
  214. Texture LOD/Mipmapping issue
  215. ACO Stuck on opening load screen, halp!
  216. Payment through paysafecard
  217. Terrible UI Options
  218. Game Freaks Out: Can't Decide Between Inputs
  219. Cannot start 2nd play through via 2nd file save slot
  220. Trial of Anubis Quest Item Bug
  221. Can't bind anything to mouse wheel.
  222. Trial of god quest suddenly dissapeared
  223. a change in recommended CPU?
  224. Controls "Jammed" In Up Position
  225. I can not kill / Damage crocodiles
  226. Trials of the Gods
  227. Patch 1.0.4 ETA, Ubi?
  228. Tomb of Amenemhat III -BUG for UBI DEVS-
  229. Short freezes in patch 1.03 and this is your solution?
  230. i cant play
  231. Can't climb out of water
  232. les arcs avec la capacité "en feu" ne peuvent pas être rengainé
  233. serious performance issue
  234. Birthright bug [SPOILER]
  235. Alienware 15 R3 2017 Performance issues
  236. SLI profile/update
  237. Star gazing divine lion broken
  238. Report Bug
  239. Permanents Microstutters
  240. Combat Bow (9999999)
  241. Alexander's Tomb Papyrus Puzzle Bug
  242. Selling outfits
  243. Selling outfits
  244. Can't vault or parkour over anything
  245. AC:O Deactivated from account?
  247. Dolby Atmos Support?
  248. Computer Auto-Shutdown
  249. Report a bug - Loot falling underground, can't loot it
  250. The battle of the nile